summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSujith H <Sujith_Haridasan@mentor.com>2014-09-08 12:58:36 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-10 11:29:50 +0100
commit8a12350e00b5443a24f3d6c7693fdde9fcb7319f (patch)
tree9fdace863dd6a3b6a2288a2a0fd174504a016acc
parentace56dcd6eed1ab92af9bdf5bd6d9b11e35a0917 (diff)
downloadopenembedded-core-8a12350e00b5443a24f3d6c7693fdde9fcb7319f.tar.gz
os-release: Adding a new recipe for operating system identification
The /etc/os-release will have the operating system identification data. Tested on target with systemd enabled. Here is the sample file looks in the file: ID=poky-ivi-systemd NAME=Yocto GENIVI Baseline (Poky/meta-ivi) VERSION=6.0+snapshot-20140721 (daisy) VERSION_ID=6.0+snapshot-20140721 PRETTY_NAME=Yocto GENIVI Baseline (Poky/meta-ivi) 6.0+snapshot-20140721 (daisy) Signed-off-by: Christopher Larson <kergoth@gmail.com> Signed-off-by: Sujith H <Sujith_Haridasan@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/os-release/os-release.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-core/os-release/os-release.bb b/meta/recipes-core/os-release/os-release.bb
new file mode 100644
index 0000000000..33e958137f
--- /dev/null
+++ b/meta/recipes-core/os-release/os-release.bb
@@ -0,0 +1,36 @@
+inherit allarch
+
+SUMMARY = "Operating system identification"
+DESCRIPTION = "The /etc/os-release file contains operating system identification data."
+LICENSE = "MIT"
+INHIBIT_DEFAULT_DEPS = "1"
+
+do_fetch[noexec] = "1"
+do_unpack[noexec] = "1"
+do_patch[noexec] = "1"
+do_configure[noexec] = "1"
+
+# Other valid fields: BUILD_ID ID_LIKE ANSI_COLOR CPE_NAME
+# HOME_URL SUPPORT_URL BUG_REPORT_URL
+OS_RELEASE_FIELDS = "ID ID_LIKE NAME VERSION VERSION_ID PRETTY_NAME"
+
+ID = "${DISTRO}"
+NAME = "${DISTRO_NAME}"
+VERSION = "${DISTRO_VERSION}${@' (%s)' % DISTRO_CODENAME if 'DISTRO_CODENAME' in d else ''}"
+VERSION_ID = "${DISTRO_VERSION}"
+PRETTY_NAME = "${DISTRO_NAME} ${VERSION}"
+BUILD_ID ?= "${DATETIME}"
+
+python do_compile () {
+ with open(d.expand('${B}/os-release'), 'w') as f:
+ for field in d.getVar('OS_RELEASE_FIELDS', True).split():
+ value = d.getVar(field, True)
+ if value:
+ f.write('{0}={1}\n'.format(field, value))
+}
+do_compile[vardeps] += "${OS_RELEASE_FIELDS}"
+
+do_install () {
+ install -d ${D}${sysconfdir}
+ install -m 0644 os-release ${D}${sysconfdir}/
+}