summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-06-04 18:48:41 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-06 00:38:38 +0100
commit95c557761de6a89cc31f5a5910be3fced5259de6 (patch)
tree1bf080865f16c91848eb233218339a8a2c6bc425
parentd00b32f4f961ceeb75e7a014209666c10cf3eb93 (diff)
downloadopenembedded-core-95c557761de6a89cc31f5a5910be3fced5259de6.tar.gz
opkg-utils: fix opkg-list-fields script
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils/0001-opkg-list-fields-fix-to-print-the-fields-again.patch41
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_0.4.0.bb1
2 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils/0001-opkg-list-fields-fix-to-print-the-fields-again.patch b/meta/recipes-devtools/opkg-utils/opkg-utils/0001-opkg-list-fields-fix-to-print-the-fields-again.patch
new file mode 100644
index 0000000000..deaf561d1e
--- /dev/null
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils/0001-opkg-list-fields-fix-to-print-the-fields-again.patch
@@ -0,0 +1,41 @@
+From df675c91f4b33490f0fa831b11162bdb0e2ff550 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Thu, 23 May 2019 20:50:45 +0000
+Subject: [PATCH] opkg-list-fields: fix to print the fields again
+
+* printing opkg.Package directly doesn't return anything useful now
+ <opkg.Package object at 0x7fd49e9f2780>
+
+* we need to call Package.print() function and specify which checksums
+ to print, we can include both md5 and sha256 for opkg-list-fields
+
+* it was changed in this commit:
+ commit 601d691dd80ef494aef069017edc5bf80aa883a1
+ Author: Alejandro del Castillo <alejandro.delcastillo@ni.com>
+ Date: Wed Dec 19 11:40:15 2018 -0600
+
+ opkg-make-index: add sha256sum support
+
+ which replaced the modified __str__ function with print(self, checksum)
+
+Upstream-Status: Backport [http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/commit/?id=5163a74a59d54b2a8374414435ece9d542dbd5e2]
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ opkg-list-fields | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/opkg-list-fields b/opkg-list-fields
+index c14a90f..8a5a588 100755
+--- a/opkg-list-fields
++++ b/opkg-list-fields
+@@ -11,5 +11,4 @@ def usage():
+ if (len(sys.argv) < 2):
+ usage()
+
+-print(opkg.Package(sys.argv[1]))
+-
++print(opkg.Package(sys.argv[1]).print(('md5','sha256')))
+--
+2.17.1
+
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.0.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.0.bb
index 9a3e06b92e..b2fb760267 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.0.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.0.bb
@@ -10,6 +10,7 @@ PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtu
SRC_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/${BPN}/snapshot/${BPN}-${PV}.tar.gz \
file://0001-Switch-all-scripts-to-use-Python-3.x.patch \
file://0001-opkg-build-do-not-set-mtime-on-data.tar.X.patch \
+ file://0001-opkg-list-fields-fix-to-print-the-fields-again.patch \
"
UPSTREAM_CHECK_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/refs/"