summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-09-13 17:02:51 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-13 17:03:54 +0100
commita5aeb873b943300e18493031ffa9e9f8ab56c2d2 (patch)
treef55f49f1d3b0dd691ebc727d7d00b48903138f71
parent8fce8180c802ad187c4df44c17207bfb026ce6c7 (diff)
downloadopenembedded-core-a5aeb873b943300e18493031ffa9e9f8ab56c2d2.tar.gz
opensp: Fix hard path in native nsgmls.
This relocation issues caused following bug and introduce one partial fix bb024d: [YOCTO #1440] But the environment val hacking is not working all the time, as nsgmsl may append wrong path in some case. This fix use search directory "-D" as solution. And more important, change the iputils' way to make doc: Use the sysid in current directory instead of parent directory, as "../" is also appended to the search directory then lead searching failure. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com> CC: Saul Would <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/opensp/opensp_1.5.bb9
-rw-r--r--meta/recipes-extended/iputils/files/nsgmls-path-fix.patch27
-rw-r--r--meta/recipes-extended/iputils/iputils_s20101006.bb1
3 files changed, 36 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opensp/opensp_1.5.bb b/meta/recipes-devtools/opensp/opensp_1.5.bb
index a402d11c72..d692137452 100644
--- a/meta/recipes-devtools/opensp/opensp_1.5.bb
+++ b/meta/recipes-devtools/opensp/opensp_1.5.bb
@@ -5,7 +5,7 @@ SECTION = "libs"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=641ff1e4511f0a87044ad42f87cb1045"
-PR = "r1"
+PR = "r2"
# At -Os it encounters calls to some inline functions which are then
# not found in any other objects with gcc 4.5
@@ -42,6 +42,13 @@ do_install_append() {
ln -sf osx sgml2xml
}
+do_install_append_virtclass-native() {
+ for util in nsgmls sgmlnorm spam spcat spent sx; do
+ create_cmdline_wrapper ${D}/${bindir}/$util \
+ -D ${sysconfdir}/sgml
+ done
+}
+
FILES_${PN} += "${datadir}/OpenSP/"
BBCLASSEXTEND = "native"
diff --git a/meta/recipes-extended/iputils/files/nsgmls-path-fix.patch b/meta/recipes-extended/iputils/files/nsgmls-path-fix.patch
new file mode 100644
index 0000000000..92bf946f2a
--- /dev/null
+++ b/meta/recipes-extended/iputils/files/nsgmls-path-fix.patch
@@ -0,0 +1,27 @@
+Fix nsgmls path issue
+
+Upstream-Status: Pending
+
+Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
+
+Index: iputils-s20101006/doc/Makefile
+===================================================================
+--- iputils-s20101006.orig/doc/Makefile 2011-09-13 20:42:27.000000000 +0800
++++ iputils-s20101006/doc/Makefile 2011-09-13 21:01:52.000000000 +0800
+@@ -27,10 +27,15 @@
+ # docbook2man produces utterly ugly output and I did not find
+ # any way to customize this but hacking backend perl script a little.
+ # Well, hence...
++# nsgmls seems append path to search directory according to the sysid path.
++# e.g. if input ../index.db, it would search $search_directory/../ rather than
++# $search_directory, which leads searching failure. Fixing nsgmls probably
++# introduce some side effects, so use this ugly hack: running nsgmls in current
++# directory, and running docbook2man in tmp directory.
+
+ $(MANFILES): index.db
+ @-mkdir tmp.db2man
+- @set -e; cd tmp.db2man; nsgmls ../$< | sgmlspl ../docbook2man-spec.pl ; mv $@ ..
++ @set -e; nsgmls $< >tmp.db2man/output; cd tmp.db2man; cat output | sgmlspl ../docbook2man-spec.pl ; mv $@ ..
+ @-rm -rf tmp.db2man
+
+ clean:
diff --git a/meta/recipes-extended/iputils/iputils_s20101006.bb b/meta/recipes-extended/iputils/iputils_s20101006.bb
index c97fce71be..5216c10821 100644
--- a/meta/recipes-extended/iputils/iputils_s20101006.bb
+++ b/meta/recipes-extended/iputils/iputils_s20101006.bb
@@ -21,6 +21,7 @@ SRC_URI = "http://www.skbuff.net/iputils/${BPN}-${PV}.tar.bz2 \
file://debian/use_gethostbyname2.diff \
file://debian/targets.diff \
file://debian/fix-arping-timeouts.diff \
+ file://nsgmls-path-fix.patch \
"
SRC_URI[md5sum] = "a36c25e9ec17e48be514dc0485e7376c"