summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2019-01-16 12:51:11 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-31 23:11:01 +0000
commita85f93b4265a20b269085d12326e32915c561e62 (patch)
tree13b0afa8699b9bd6139086a6d8a557f51f1ceb0b
parente07272491e9f4d81a4c3797c585958163657bf9c (diff)
downloadopenembedded-core-a85f93b4265a20b269085d12326e32915c561e62.tar.gz
util-linux: remove erroneous patch (qsort_r)
The patch in question is patching the code to use qsort() instead of qsort_r(), without adopting the compare function. This is a major issue, because the compare function as written is evaluating / accessing a third argument, which is not passed with this OE patch, causing access to random memory. Given this patch was added so as to support (old) linux (host) distros which might not provide qsort_r(), according to the git history, and given these days util-linux detects availability of qsort_r() during configure phase, and given musl builds (which doesn't provide qsort_r() either) work without problem, the right solution is to simply drop this invalid patch. Do so. Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/util-linux/util-linux/util-linux-native-qsort.patch33
-rw-r--r--meta/recipes-core/util-linux/util-linux_2.32.1.bb6
2 files changed, 0 insertions, 39 deletions
diff --git a/meta/recipes-core/util-linux/util-linux/util-linux-native-qsort.patch b/meta/recipes-core/util-linux/util-linux/util-linux-native-qsort.patch
deleted file mode 100644
index 68bf22de8c..0000000000
--- a/meta/recipes-core/util-linux/util-linux/util-linux-native-qsort.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From f220d809be1baa654503bf6ff52f3630b0d7015c Mon Sep 17 00:00:00 2001
-From: Robert Yang <liezhi.yang@windriver.com>
-Date: Wed, 26 Mar 2014 01:30:29 +0000
-Subject: [PATCH] sun.c: use qsort() to instead of qsort_r()
-
-qsort_r() was added to glibc in version 2.8, so there is no qsort_r() on
-the host like CentOS 5.x.
-
-Upstream-Status: Inappropriate [Other]
-
-Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
----
- libfdisk/src/sun.c | 5 ++---
- 1 file changed, 2 insertions(+), 3 deletions(-)
-
-Index: util-linux-2.24.2/libfdisk/src/sun.c
-===================================================================
---- util-linux-2.24.2.orig/libfdisk/src/sun.c
-+++ util-linux-2.24.2/libfdisk/src/sun.c
-@@ -431,10 +431,9 @@ static int sun_verify_disklabel(struct f
- }
- verify_sun_starts = starts;
-
-- qsort_r(array,ARRAY_SIZE(array),sizeof(array[0]),
-- (int (*)(const void *,const void *,void *)) verify_sun_cmp,
-- verify_sun_starts);
--
-+ qsort(array,ARRAY_SIZE(array),sizeof(array[0]),
-+ (int (*)(const void *,const void *)) verify_sun_cmp);
-+
- if (array[0] == -1) {
- fdisk_info(cxt, _("No partitions defined."));
- return 0;
diff --git a/meta/recipes-core/util-linux/util-linux_2.32.1.bb b/meta/recipes-core/util-linux/util-linux_2.32.1.bb
index b0492afff3..0f860c221b 100644
--- a/meta/recipes-core/util-linux/util-linux_2.32.1.bb
+++ b/meta/recipes-core/util-linux/util-linux_2.32.1.bb
@@ -1,14 +1,8 @@
require util-linux.inc
-# To support older hosts, we need to patch and/or revert
-# some upstream changes. Only do this for native packages.
-OLDHOST = ""
-OLDHOST_class-native = "file://util-linux-native-qsort.patch"
-
SRC_URI += "file://configure-sbindir.patch \
file://runuser.pamd \
file://runuser-l.pamd \
- ${OLDHOST} \
file://ptest.patch \
file://run-ptest \
file://display_testname_for_subtest.patch \