summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-01-08 16:25:29 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-11 10:29:37 +0000
commita921a96e84f4d0b3f3d29a571981de08eb148e15 (patch)
treef3b893bb85b8e7142305a9d2994730626e7a78aa
parent63af0edcd954fac530ba17b04e5df5837cddc0a4 (diff)
downloadopenembedded-core-a921a96e84f4d0b3f3d29a571981de08eb148e15.tar.gz
openssh: use tarballs instead of git
This was change to git recently to obtain openssl 1.1 compatible pre-release code (before 7.9 was out), however tarballs are preferred, and with them upstream version checks work (openssh uses a weird git tag scheme). Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-connectivity/openssh/openssh_7.9p1.bb (renamed from meta/recipes-connectivity/openssh/openssh_7.9p1+git.bb)8
1 files changed, 3 insertions, 5 deletions
diff --git a/meta/recipes-connectivity/openssh/openssh_7.9p1+git.bb b/meta/recipes-connectivity/openssh/openssh_7.9p1.bb
index d79ffe1971..2a23f64b89 100644
--- a/meta/recipes-connectivity/openssh/openssh_7.9p1+git.bb
+++ b/meta/recipes-connectivity/openssh/openssh_7.9p1.bb
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=429658c6612f3a9b1293782366ab29d8"
DEPENDS = "zlib openssl"
DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
-SRC_URI = "git://github.com/openssh/openssh-portable;branch=master \
+SRC_URI = "http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.gz \
file://sshd_config \
file://ssh_config \
file://init \
@@ -25,13 +25,11 @@ SRC_URI = "git://github.com/openssh/openssh-portable;branch=master \
file://sshd_check_keys \
file://add-test-support-for-busybox.patch \
"
+SRC_URI[md5sum] = "c6af50b7a474d04726a5aa747a5dce8f"
+SRC_URI[sha256sum] = "6b4b3ba2253d84ed3771c8050728d597c91cfce898713beb7b64a305b6f11aad"
PAM_SRC_URI = "file://sshd"
-SRCREV = "aede1c34243a6f7feae2fb2cb686ade5f9be6f3d"
-
-S = "${WORKDIR}/git"
-
inherit useradd update-rc.d update-alternatives systemd
USERADD_PACKAGES = "${PN}-sshd"