summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2018-02-19 10:36:52 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-24 10:31:35 +0000
commitbff4ad7d6f62131a9b91a4063600e6f3edb8843c (patch)
treeb41cc5542a423f99188d5b3b5cbbf985a0a466e3
parent9763c9d649a22f9024d832eb625bee35b583e717 (diff)
downloadopenembedded-core-bff4ad7d6f62131a9b91a4063600e6f3edb8843c.tar.gz
pkgconf: upgrade to version 1.4.2
pkgconf improved compatibility with freedesktop.org pkg-config. So, we don't need to unset PKG_CONFIG_SYSROOT_DIR in wrappers. Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/pkgconf/pkgconf/pkg-config-esdk.in4
-rw-r--r--meta/recipes-devtools/pkgconf/pkgconf/pkg-config-native.in1
-rwxr-xr-xmeta/recipes-devtools/pkgconf/pkgconf/pkg-config-wrapper9
-rw-r--r--meta/recipes-devtools/pkgconf/pkgconf_1.4.2.bb (renamed from meta/recipes-devtools/pkgconf/pkgconf_1.4.0.bb)4
4 files changed, 3 insertions, 15 deletions
diff --git a/meta/recipes-devtools/pkgconf/pkgconf/pkg-config-esdk.in b/meta/recipes-devtools/pkgconf/pkgconf/pkg-config-esdk.in
index 4fc9b0a4a7..d4ac71dff2 100644
--- a/meta/recipes-devtools/pkgconf/pkgconf/pkg-config-esdk.in
+++ b/meta/recipes-devtools/pkgconf/pkgconf/pkg-config-esdk.in
@@ -5,7 +5,6 @@
if [ "pkg-config-native" = "`basename $0`" ] ; then
PKG_CONFIG_PATH="@PATH_NATIVE@"
PKG_CONFIG_LIBDIR="@LIBDIR_NATIVE@"
- unset PKG_CONFIG_SYSROOT_DIR
else
# in this case check if we are in the esdk
if [ "$OE_SKIP_SDK_CHECK" = "1" ] ; then
@@ -16,9 +15,8 @@ else
if ( echo $parentpid_info | grep -q check-lxdialog ) ; then
PKG_CONFIG_PATH="@PATH_NATIVE@"
PKG_CONFIG_LIBDIR="@LIBDIR_NATIVE@"
- unset PKG_CONFIG_SYSROOT_DIR
fi
fi
fi
-pkg-config.real "$@"
+pkg-config "$@"
diff --git a/meta/recipes-devtools/pkgconf/pkgconf/pkg-config-native.in b/meta/recipes-devtools/pkgconf/pkgconf/pkg-config-native.in
index 9ed30a0d80..c2e86e5ac1 100644
--- a/meta/recipes-devtools/pkgconf/pkgconf/pkg-config-native.in
+++ b/meta/recipes-devtools/pkgconf/pkgconf/pkg-config-native.in
@@ -1,6 +1,5 @@
#! /bin/sh
PKG_CONFIG_PATH="@PATH_NATIVE@"
-unset PKG_CONFIG_SYSROOT_DIR
pkg-config "$@"
diff --git a/meta/recipes-devtools/pkgconf/pkgconf/pkg-config-wrapper b/meta/recipes-devtools/pkgconf/pkgconf/pkg-config-wrapper
index 695f349566..fc9b48803f 100755
--- a/meta/recipes-devtools/pkgconf/pkgconf/pkg-config-wrapper
+++ b/meta/recipes-devtools/pkgconf/pkgconf/pkg-config-wrapper
@@ -4,13 +4,4 @@
# Copyright (C) 2015 Christopher Larson <chris_larson@mentor.com>
# License: MIT (see COPYING.MIT at the root of the repository for terms)
-for arg; do
- case "$arg" in
- --variable|--variable=*)
- # pkg-config doesn't sysroot-prefix user variables
- unset PKG_CONFIG_SYSROOT_DIR
- ;;
- esac
-done
-
exec pkgconf "$@"
diff --git a/meta/recipes-devtools/pkgconf/pkgconf_1.4.0.bb b/meta/recipes-devtools/pkgconf/pkgconf_1.4.2.bb
index 48ba5982e3..ea7b666021 100644
--- a/meta/recipes-devtools/pkgconf/pkgconf_1.4.0.bb
+++ b/meta/recipes-devtools/pkgconf/pkgconf_1.4.2.bb
@@ -21,8 +21,8 @@ SRC_URI = "\
file://pkg-config-native.in \
file://pkg-config-esdk.in \
"
-SRC_URI[md5sum] = "c509c0dad5a70aa4bc3210557b7eafce"
-SRC_URI[sha256sum] = "1d112ff35dad516ffbfbdb013df3a035140618fe7632ec44ffa894a9c713301b"
+SRC_URI[md5sum] = "678d242b4eef1754bba6a58642af10bb"
+SRC_URI[sha256sum] = "bab39371d4ab972be1d539a8b10b6cc21f8eafc97f617102e667e82bd32eb234"
inherit autotools update-alternatives