summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2020-01-06 18:30:32 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-15 22:41:45 +0000
commitc6b00b5594adec0a7d7a7f3617fb99b65ea8d9f1 (patch)
treebd8e17741ab015e4d8cf9c972a0ca4d275b1e125
parent9521c66e0edb2b36c3d5c777ec7a7158b40452d4 (diff)
downloadopenembedded-core-c6b00b5594adec0a7d7a7f3617fb99b65ea8d9f1.tar.gz
gnupg: Read GNUPG_BINDIR from environment variables for nativesdk
There is already a relocate.patch for native which is used for reading GNUPG_BINDIR from environment variables, now also enable it for nativesdk. Otherwise, command like the following one doesn't work for nativesdk: $ gpg-connect-agent --homedir ../keys/ reloadagent /bye gpg-connect-agent: no running gpg-agent - starting '/opt/path/to/sysroots/x86_64-wrlinuxsdk-linux/usr/bin/gpg-agent' gpg-connect-agent: failed to start agent '/opt/path/sysroots/x86_64-wrlinuxsdk-linux/usr/bin/gpg-agent': No such file or directory Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/gnupg/gnupg_2.2.19.bb16
1 files changed, 12 insertions, 4 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_2.2.19.bb b/meta/recipes-support/gnupg/gnupg_2.2.19.bb
index 76c09ff687..c07bff13be 100644
--- a/meta/recipes-support/gnupg/gnupg_2.2.19.bb
+++ b/meta/recipes-support/gnupg/gnupg_2.2.19.bb
@@ -18,6 +18,7 @@ SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
"
SRC_URI_append_class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch \
file://relocate.patch"
+SRC_URI_append_class-nativesdk = " file://relocate.patch"
SRC_URI[md5sum] = "cb3b373d08ba078c325299945a7f2818"
SRC_URI[sha256sum] = "242554c0e06f3a83c420b052f750b65ead711cc3fddddb5e7274fcdbb4e9dec0"
@@ -60,10 +61,17 @@ do_install_append() {
}
do_install_append_class-native() {
- create_wrapper ${D}${bindir}/gpg2 GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
- create_wrapper ${D}${bindir}/gpgconf GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
- create_wrapper ${D}${bindir}/gpg-agent GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
- create_wrapper ${D}${bindir}/gpg-connect-agent GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
+ create_wrappers ${STAGING_BINDIR_NATIVE}
+}
+
+do_install_append_class-nativesdk() {
+ create_wrappers ${SDKPATHNATIVE}${bindir_nativesdk}
+}
+
+create_wrappers() {
+ for i in gpg2 gpgconf gpg-agent gpg-connect-agent; do
+ create_wrapper ${D}${bindir}/$i GNUPG_BINDIR=$1
+ done
}
PACKAGECONFIG ??= "gnutls"