summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-03-14 08:50:02 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-14 23:31:11 +0000
commitf38a80cc0cb4affab22080ead179b55d5a665ee6 (patch)
tree7cee7f1e73c4e11be6cafaca737f8055ca31cb5b
parente84496b2d5a0004e697a79ba5792300af282be55 (diff)
downloadopenembedded-core-f38a80cc0cb4affab22080ead179b55d5a665ee6.tar.gz
gpgme: fix packaging warnings
Use rmdir since it is currently empty, and we can catch if it gets used later Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/gpgme/gpgme_1.3.1.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-support/gpgme/gpgme_1.3.1.bb b/meta/recipes-support/gpgme/gpgme_1.3.1.bb
index 9ffedbae2d..4bcb57ab37 100644
--- a/meta/recipes-support/gpgme/gpgme_1.3.1.bb
+++ b/meta/recipes-support/gpgme/gpgme_1.3.1.bb
@@ -14,7 +14,7 @@ SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${PV}.tar.bz2 \
SRC_URI[md5sum] = "90afa8436ce2b2683c001c824bd22601"
SRC_URI[sha256sum] = "15ef27a875ae0d79d7446fd931deda11438e724ffbeac74449ed19cba23df4d4"
DEPENDS = "libgpg-error libassuan pth"
-PR = "r0"
+PR = "r1"
EXTRA_OECONF = "--with-pth=${STAGING_DIR_HOST} --without-pth-test \
--with-gpg=${bindir}/gpg --without-gpgsm"
@@ -26,3 +26,7 @@ FILES_${PN}-pth = "${libdir}/libgpgme-pth.so.*"
FILES_${PN}-pthread = "${libdir}/libgpgme-pthread.so.*"
FILES_${PN} = "${libdir}/libgpgme.so.*"
FILES_${PN}-dev += "${bindir}/gpgme-config ${datadir}/common-lisp/source/gpgme/*"
+
+do_install_append() {
+ rmdir ${D}/usr/libexec
+}