summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2018-07-27 15:36:17 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-30 12:44:28 +0100
commitf55d5a8022dda18f3e9aa4138dc1961d9ef979c4 (patch)
tree97379ca7b080ef65076074abca95de0733920c96
parent50864df5b0eb3d1704e8fe75c06e957af0b41c38 (diff)
downloadopenembedded-core-f55d5a8022dda18f3e9aa4138dc1961d9ef979c4.tar.gz
python3-subunit: add it for oeqa
- It is required by oeqa, add it so that we can add nativesdk-python3-subunit to buildtools-tarball. - The original one is python-subunit_1.1.0.bb which is from meta-openstack layer, I divided it into python-subunit.inc and python3-subunit_1.1.0.bb and extended to nativesdk. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python-subunit.inc14
-rw-r--r--meta/recipes-devtools/python/python3-subunit_1.1.0.bb2
2 files changed, 16 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-subunit.inc b/meta/recipes-devtools/python/python-subunit.inc
new file mode 100644
index 0000000000..f893e7a371
--- /dev/null
+++ b/meta/recipes-devtools/python/python-subunit.inc
@@ -0,0 +1,14 @@
+SUMMARY = "Python implementation of subunit test streaming protocol"
+HOMEPAGE = "https://pypi.python.org/pypi/python-subunit/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://README;md5=e5b524e1b2c67c88fc64439ee4a850aa"
+
+PYPI_PACKAGE = "python-subunit"
+
+SRC_URI[md5sum] = "d2c09c93346077ced675c9f718e6a0f1"
+SRC_URI[sha256sum] = "d9a7606e9610828d68c1d2f0f5abbb421e34e518b8f4882c8b2e08176281bf88"
+
+inherit pypi
+
+BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-devtools/python/python3-subunit_1.1.0.bb b/meta/recipes-devtools/python/python3-subunit_1.1.0.bb
new file mode 100644
index 0000000000..2ece4451df
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-subunit_1.1.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-subunit.inc