aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openmoko
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-07-22 16:26:54 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-07-22 16:26:54 +0000
commit43aab47cfc79563a192b49f0ca40a86d04e93f8f (patch)
tree496118724ae8bcef5f2d646d4039802b758f2bb8 /meta-openmoko
parent0a968eeb415dc0aa829b1457ec8f404926ea6780 (diff)
downloadopenembedded-core-43aab47cfc79563a192b49f0ca40a86d04e93f8f.tar.gz
gsmd2: taken from OE, cleaned, fixed deps/building, improved packaging
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4933 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-openmoko')
-rw-r--r--meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb21
-rw-r--r--meta-openmoko/packages/freesmartphone/gsmd2/fix-dbus-location.patch135
-rw-r--r--meta-openmoko/packages/freesmartphone/gsmd2_git.bb25
3 files changed, 181 insertions, 0 deletions
diff --git a/meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb b/meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb
new file mode 100644
index 0000000000..410ac36e2f
--- /dev/null
+++ b/meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "GSM 07.10 muxer userspace daemon"
+HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/gsm0710muxd"
+AUTHOR = "M. Dietrich"
+SECTION = "console/network"
+DEPENDS = "dbus dbus-glib"
+LICENSE = "GPL"
+PV = "0.9.1+gitr${SRCREV}"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/gsm0710muxd.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+# install init script for people who want to manually
+# start/stop it, but don't add runlevels.
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 data/gsm0710muxd ${D}${sysconfdir}/init.d/
+}
+
+FILES_${PN} += "${datadir} ${sysconfdir}"
diff --git a/meta-openmoko/packages/freesmartphone/gsmd2/fix-dbus-location.patch b/meta-openmoko/packages/freesmartphone/gsmd2/fix-dbus-location.patch
new file mode 100644
index 0000000000..01c598af48
--- /dev/null
+++ b/meta-openmoko/packages/freesmartphone/gsmd2/fix-dbus-location.patch
@@ -0,0 +1,135 @@
+---
+ libfreesmartphone/Makefile.am | 14 +++++++-------
+ serial/Makefile.am | 2 +-
+ src/Makefile.am | 14 +++++++-------
+ 3 files changed, 15 insertions(+), 15 deletions(-)
+
+--- git.orig/libfreesmartphone/Makefile.am
++++ git/libfreesmartphone/Makefile.am
+@@ -21,47 +21,47 @@ fso-marshallers.h: $(top_srcdir)/src/sma
+ fso-marshallers.c: $(top_srcdir)/src/smartphone_marshaller.txt
+ glib-genmarshal --prefix fso_marshaller --body $(top_srcdir)/src/smartphone_marshaller.txt > fso-marshallers.c
+
+
+ freesmartphone-call-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Call.xml
+- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
++ $(LIBTOOL) --mode=execute dbus-binding-tool \
+ --prefix=smartphone_call --mode=glib-client \
+ --output=freesmartphone-call-binding.h \
+ $(top_srcdir)/interface/org.freesmartphone.GSM.Call.xml
+
+ freesmartphone-sms-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.SMS.xml
+- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
++ $(LIBTOOL) --mode=execute dbus-binding-tool \
+ --prefix=smartphone_sms --mode=glib-client \
+ --output=freesmartphone-sms-binding.h \
+ $(top_srcdir)/interface/org.freesmartphone.GSM.SMS.xml
+
+ freesmartphone-device-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Device.xml
+- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
++ $(LIBTOOL) --mode=execute dbus-binding-tool \
+ --prefix=smartphone_device --mode=glib-client \
+ --output=freesmartphone-device-binding.h \
+ $(top_srcdir)/interface/org.freesmartphone.GSM.Device.xml
+
+ freesmartphone-sim-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.SIM.xml
+- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
++ $(LIBTOOL) --mode=execute dbus-binding-tool \
+ --prefix=smartphone_sim --mode=glib-client \
+ --output=freesmartphone-sim-binding.h \
+ $(top_srcdir)/interface/org.freesmartphone.GSM.SIM.xml
+
+ freesmartphone-phonebook-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Phonebook.xml
+- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
++ $(LIBTOOL) --mode=execute dbus-binding-tool \
+ --prefix=smartphone_phonebook --mode=glib-client \
+ --output=freesmartphone-phonebook-binding.h \
+ $(top_srcdir)/interface/org.freesmartphone.GSM.Phonebook.xml
+
+ freesmartphone-pdp-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.PDP.xml
+- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
++ $(LIBTOOL) --mode=execute dbus-binding-tool \
+ --prefix=smartphone_pdp --mode=glib-client \
+ --output=freesmartphone-pdp-binding.h \
+ $(top_srcdir)/interface/org.freesmartphone.GSM.PDP.xml
+
+ freesmartphone-network-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Network.xml
+- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
++ $(LIBTOOL) --mode=execute dbus-binding-tool \
+ --prefix=smartphone_network --mode=glib-client \
+ --output=freesmartphone-network-binding.h \
+ $(top_srcdir)/interface/org.freesmartphone.GSM.Network.xml
+
+ CLEANFILES = $(BUILT_SOURCES)
+--- git.orig/serial/Makefile.am
++++ git/serial/Makefile.am
+@@ -11,11 +11,11 @@ COMMON_LDFLAGS = -avoid-version -module
+ BUILT_SOURCES = fsomuxer_client.h
+
+ CLEANFILES = $(BUILT_SOURCES)
+
+ fsomuxer_client.h: fsomuxer.xml
+- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
++ $(LIBTOOL) --mode=execute dbus-binding-tool \
+ --mode=glib-client \
+ --output=fsomuxer_client.h \
+ fsomuxer.xml
+
+
+--- git.orig/src/Makefile.am
++++ git/src/Makefile.am
+@@ -30,47 +30,47 @@ dbus_marshal.h: $(srcdir)/smartphone_mar
+ dbus_marshal.c: $(srcdir)/smartphone_marshaller.txt
+ glib-genmarshal --prefix gsmd_smartphone_marshaller --body $(srcdir)/smartphone_marshaller.txt > dbus_marshal.c
+
+
+ dbus_call_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Call.xml
+- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
++ $(LIBTOOL) --mode=execute dbus-binding-tool \
+ --prefix=smartphone_call --mode=glib-server \
+ --output=dbus_call_glue.h \
+ $(top_srcdir)/interface/org.freesmartphone.GSM.Call.xml
+
+ dbus_sms_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.SMS.xml
+- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
++ $(LIBTOOL) --mode=execute dbus-binding-tool \
+ --prefix=smartphone_sms --mode=glib-server \
+ --output=dbus_sms_glue.h \
+ $(top_srcdir)/interface/org.freesmartphone.GSM.SMS.xml
+
+ dbus_device_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Device.xml
+- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
++ $(LIBTOOL) --mode=execute dbus-binding-tool \
+ --prefix=smartphone_device --mode=glib-server \
+ --output=dbus_device_glue.h \
+ $(top_srcdir)/interface/org.freesmartphone.GSM.Device.xml
+
+ dbus_sim_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.SIM.xml
+- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
++ $(LIBTOOL) --mode=execute dbus-binding-tool \
+ --prefix=smartphone_sim --mode=glib-server \
+ --output=dbus_sim_glue.h \
+ $(top_srcdir)/interface/org.freesmartphone.GSM.SIM.xml
+
+ dbus_phonebook_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Phonebook.xml
+- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
++ $(LIBTOOL) --mode=execute dbus-binding-tool \
+ --prefix=smartphone_phonebook --mode=glib-server \
+ --output=dbus_phonebook_glue.h \
+ $(top_srcdir)/interface/org.freesmartphone.GSM.Phonebook.xml
+
+ dbus_pdp_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.PDP.xml
+- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
++ $(LIBTOOL) --mode=execute dbus-binding-tool \
+ --prefix=smartphone_pdp --mode=glib-server \
+ --output=dbus_pdp_glue.h \
+ $(top_srcdir)/interface/org.freesmartphone.GSM.PDP.xml
+
+ dbus_network_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Network.xml
+- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
++ $(LIBTOOL) --mode=execute dbus-binding-tool \
+ --prefix=smartphone_network --mode=glib-server \
+ --output=dbus_network_glue.h \
+ $(top_srcdir)/interface/org.freesmartphone.GSM.Network.xml
+
+ gsmd-types.h: $(srcdir)/gsmd-error.h
diff --git a/meta-openmoko/packages/freesmartphone/gsmd2_git.bb b/meta-openmoko/packages/freesmartphone/gsmd2_git.bb
new file mode 100644
index 0000000000..5983702d81
--- /dev/null
+++ b/meta-openmoko/packages/freesmartphone/gsmd2_git.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "GSM 07.07 phone server"
+HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/gsm0710muxd"
+AUTHOR = "Ixonos Team"
+SECTION = "console/network"
+DEPENDS = "dbus-native dbus dbus-glib"
+RDEPENDS = "gsm0710muxd"
+LICENSE = "GPL"
+PV = "0.1.0+gitr${SRCREV}"
+PR = "r1"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/gsmd2.git;protocol=git;branch=master \
+ file://fix-dbus-location.patch;patch=1"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-tests"
+
+PACKAGES =+ "libgsmd2 libfreesmartphone"
+
+FILES_libgsmd2 = "${libdir}/libgsmd2.so.* ${libdir}/gsmd2/*.so"
+FILES_libfreesmartphone = "${libdir}/libfreesmartphone.so.*"
+FILES_${PN}-dev += "${libdir}/gsmd2/*.*a"
+FILES_${PN} = "${bindir}/gsmd2"