summaryrefslogtreecommitdiffstats
path: root/meta/classes/distutils.bbclass
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2015-06-11 15:38:54 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-23 11:38:10 +0100
commita0460ac8a2595d4b064b483ca1f282a255ae6411 (patch)
tree6d532e75e32aad9e023120147c4deb4bf2ee92cd /meta/classes/distutils.bbclass
parentdfae10889ab0fce2bae94294a78f4ea0aaf1b81e (diff)
downloadopenembedded-core-a0460ac8a2595d4b064b483ca1f282a255ae6411.tar.gz
distutils: regenerate pyc files after being modified by sed
py files are edited by sed and therefore *.pyc files are recreated on first boot, but if you have a read-only filesystem this is not possible. This patch creates pyc files directly after the py files are modified. [YOCTO #7722] Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Thomas Roos <roosesweb@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/classes/distutils.bbclass')
-rw-r--r--meta/classes/distutils.bbclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/classes/distutils.bbclass b/meta/classes/distutils.bbclass
index c0bb573cf8..2498685d66 100644
--- a/meta/classes/distutils.bbclass
+++ b/meta/classes/distutils.bbclass
@@ -42,8 +42,8 @@ distutils_do_install() {
bbfatal "${PYTHON_PN} setup.py install execution failed."
# support filenames with *spaces*
- # only modify file if it contains path to avoid recompilation on the target
- find ${D} -name "*.py" -exec grep -q ${D} {} \; -exec sed -i -e s:${D}::g {} \;
+ # only modify file if it contains path and recompile it
+ find ${D} -name "*.py" -exec grep -q ${D} {} \; -exec sed -i -e s:${D}::g {} \; -exec ${STAGING_BINDIR_NATIVE}/python-native/python -mcompileall {} \;
if test -e ${D}${bindir} ; then
for i in ${D}${bindir}/* ; do \