aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/distutils3.bbclass
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2016-03-21 18:10:58 +1300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-23 14:24:24 +0000
commit970a02061b474a238f57cd0cc4db7b62e36dfa3d (patch)
tree8413060931d426e4aa260ecab3d6eb90a5f58cec /meta/classes/distutils3.bbclass
parent52f9b12601c02f1585438f890f847b4596170362 (diff)
downloadopenembedded-core-970a02061b474a238f57cd0cc4db7b62e36dfa3d.tar.gz
classes/distutils*: don't hide logs when setup script fails
We need to see the output of the setup script in the error message because what we are having bbfatal print here doesn't completely describe what went wrong, thus we should use bbfatal_log here and not bbfatal. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/distutils3.bbclass')
-rw-r--r--meta/classes/distutils3.bbclass8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/classes/distutils3.bbclass b/meta/classes/distutils3.bbclass
index 443bf3ac4b..4f6ca44822 100644
--- a/meta/classes/distutils3.bbclass
+++ b/meta/classes/distutils3.bbclass
@@ -19,7 +19,7 @@ distutils3_do_compile() {
BUILD_SYS=${BUILD_SYS} HOST_SYS=${SYS} \
${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py \
build ${DISTUTILS_BUILD_ARGS} || \
- bbfatal "${PYTHON_PN} setup.py build_ext execution failed."
+ bbfatal_log "${PYTHON_PN} setup.py build_ext execution failed."
}
distutils3_do_compile[vardepsexclude] = "MACHINE"
@@ -32,7 +32,7 @@ distutils3_stage_headers() {
fi
BUILD_SYS=${BUILD_SYS} HOST_SYS=${SYS} \
${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py install_headers ${DISTUTILS_STAGE_HEADERS_ARGS} || \
- bbfatal "${PYTHON_PN} setup.py install_headers execution failed."
+ bbfatal_log "${PYTHON_PN} setup.py install_headers execution failed."
}
distutils3_stage_headers[vardepsexclude] = "MACHINE"
@@ -48,7 +48,7 @@ distutils3_stage_all() {
PYTHONPATH=${STAGING_DIR_HOST}${PYTHON_SITEPACKAGES_DIR} \
BUILD_SYS=${BUILD_SYS} HOST_SYS=${SYS} \
${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py install ${DISTUTILS_STAGE_ALL_ARGS} || \
- bbfatal "${PYTHON_PN} setup.py install (stage) execution failed."
+ bbfatal_log "${PYTHON_PN} setup.py install (stage) execution failed."
}
distutils3_stage_all[vardepsexclude] = "MACHINE"
@@ -64,7 +64,7 @@ distutils3_do_install() {
PYTHONPATH=${D}${PYTHON_SITEPACKAGES_DIR} \
BUILD_SYS=${BUILD_SYS} HOST_SYS=${SYS} \
${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py install --install-lib=${D}/${PYTHON_SITEPACKAGES_DIR} ${DISTUTILS_INSTALL_ARGS} || \
- bbfatal "${PYTHON_PN} setup.py install execution failed."
+ bbfatal_log "${PYTHON_PN} setup.py install execution failed."
# support filenames with *spaces*
find ${D} -name "*.py" -exec grep -q ${D} {} \; -exec sed -i -e s:${D}::g {} \;