summaryrefslogtreecommitdiffstats
path: root/meta/classes/multilib.bbclass
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2012-09-26 18:01:04 -0500
committerSaul Wold <sgw@linux.intel.com>2012-10-26 09:12:15 -0700
commit15834451525453e0f7ceac25d4f98117f1825f37 (patch)
tree6911b5c1f1a747e4a2c877cfb75ac6f226cfb052 /meta/classes/multilib.bbclass
parent132a182e2f6c330aa645de42c1aeb386e43bddd3 (diff)
downloadopenembedded-core-15834451525453e0f7ceac25d4f98117f1825f37.tar.gz
openembedded-core-15834451525453e0f7ceac25d4f98117f1825f37.tar.bz2
openembedded-core-15834451525453e0f7ceac25d4f98117f1825f37.zip
multilib - crosssdk: Stop building multilib for crosssdk packages
Crosssdk packages are not actually multilib packages, so treat them the same as other nativesdk packages in the multilib, base, and classextend components. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/classes/multilib.bbclass')
-rw-r--r--meta/classes/multilib.bbclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/classes/multilib.bbclass b/meta/classes/multilib.bbclass
index de6e59e39d..c249925441 100644
--- a/meta/classes/multilib.bbclass
+++ b/meta/classes/multilib.bbclass
@@ -28,7 +28,7 @@ python multilib_virtclass_handler () {
if bb.data.inherits_class('native', e.data):
raise bb.parse.SkipPackage("We can't extend native recipes")
- if bb.data.inherits_class('nativesdk', e.data):
+ if bb.data.inherits_class('nativesdk', e.data) or bb.data.inherits_class('crosssdk', e.data):
raise bb.parse.SkipPackage("We can't extend nativesdk recipes")
save_var_name=e.data.getVar("MULTILIB_SAVE_VARNAME", True) or ""
@@ -101,7 +101,7 @@ python do_package_qa_multilib() {
for i in values:
if i.startswith('virtual/'):
i = i[len('virtual/'):]
- if (not i.startswith('kernel-module')) and (not i.startswith(mlprefix)) and (not 'cross-canadian' in i):
+ if (not i.startswith('kernel-module')) and (not i.startswith(mlprefix)) and (not 'cross-canadian' in i) and (not i.startswith("nativesdk-")):
candidates.append(i)
if len(candidates) > 0:
bb.warn("Multilib QA Issue: %s package %s - suspicious values '%s' in %s"