summaryrefslogtreecommitdiffstats
path: root/meta/classes/setuptools.bbclass
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-03-09 22:08:32 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-02 22:34:32 +0000
commit8bb0206ed67228c88dd5bc2d8b36ce28f48b78f4 (patch)
treef1272b722dc4ebb76b8cdb07121b5ae9f69d98cd /meta/classes/setuptools.bbclass
parentae931c2cf9e48e1fb74b4b727dbf668ea880023f (diff)
downloadopenembedded-core-8bb0206ed67228c88dd5bc2d8b36ce28f48b78f4.tar.gz
classes: Add distutils for python3
In line with python2 add distutils and setuptools classes for handing python3 Use python-distribute instead of python-setuptools in setuptools bbclass Remove --single-version-externally-managed since its setuptools specific and we dont use it anymore Do build_ext as separate step during compile Add DISTUTILS_BUILD_EXT_ARGS for modules to pass flags to build_ext step in setup.py Add build_ext as sepate step during compile and add the cross sysrooted library and headers since we are cross compiling Use ${PYTHON_PN} in place of hardcoding python name Remove the /etc/share if its empty Since OE-Core times we now have machine specific sysroots for targets unlike before when we used arch specific sysroots so reflect that here Use MACHINE for sysroot when not building for build host Python's machinery replaces directories in sysroot path to match OE's staging area sysroots. Earlier we use to have HOST_SYS represent sysroot always but now we use MACHINE to represent target sysroots but HOST_SYS to represent host sysroot. This patch caters to that difference Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/classes/setuptools.bbclass')
-rw-r--r--meta/classes/setuptools.bbclass3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta/classes/setuptools.bbclass b/meta/classes/setuptools.bbclass
index ba9cf13295..56343b1c73 100644
--- a/meta/classes/setuptools.bbclass
+++ b/meta/classes/setuptools.bbclass
@@ -1,9 +1,8 @@
inherit distutils
-DEPENDS += "python-setuptools-native"
+DEPENDS += "python-distribute-native"
DISTUTILS_INSTALL_ARGS = "--root=${D} \
- --single-version-externally-managed \
--prefix=${prefix} \
--install-lib=${PYTHON_SITEPACKAGES_DIR} \
--install-data=${datadir}"