aboutsummaryrefslogtreecommitdiffstats
path: root/meta/conf/local.conf.sample
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-08-17 17:34:59 +0100
committerJoshua Lock <josh@linux.intel.com>2010-08-17 17:41:20 +0100
commite624b2700abc93990b58bef0ba9447373148a31c (patch)
tree1e8c6773d5eebb7177da07499fa33647e2b4945d /meta/conf/local.conf.sample
parent2225e1214285f0e9a3c0ee2962b3d678c5c05292 (diff)
downloadopenembedded-core-e624b2700abc93990b58bef0ba9447373148a31c.tar.gz
build/conf: move sample conf files to meta/conf
Currently rm -fr build breaks things badly but will work if we move the sample configuration files to meta/conf - this patch does so. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/conf/local.conf.sample')
-rw-r--r--meta/conf/local.conf.sample151
1 files changed, 151 insertions, 0 deletions
diff --git a/meta/conf/local.conf.sample b/meta/conf/local.conf.sample
new file mode 100644
index 0000000000..66acaa49a7
--- /dev/null
+++ b/meta/conf/local.conf.sample
@@ -0,0 +1,151 @@
+# CONF_VERSION is increased each time build/conf/ changes incompatibly
+CONF_VERSION = "1"
+
+# Uncomment and change to cache the files Poky downloads in an alternative
+# location, default it ${TOPDIR}/sources
+#DL_DIR ?= "${TOPDIR}/sources"
+# Uncomment and change to cache Poky's built staging output in an alternative
+# location, default ${TOPDIR}/pstage
+#PSTAGE_DIR ?= "${TOPDIR}/pstage"
+
+# Uncomment and set to allow bitbake to execute multiple tasks at once.
+# For a quadcore, BB_NUMBER_THREADS = "4", PARALLEL_MAKE = "-j 4" would
+# be appropriate.
+# BB_NUMBER_THREADS = "4"
+# Also, make can be passed flags so it run parallel threads e.g.:
+# PARALLEL_MAKE = "-j 4"
+
+# The machine to target
+MACHINE ?= "qemux86"
+
+# Other supported machines
+#MACHINE ?= "qemuarm"
+#MACHINE ?= "netbook"
+#MACHINE ?= "c7x0"
+#MACHINE ?= "akita"
+#MACHINE ?= "spitz"
+#MACHINE ?= "nokia770"
+#MACHINE ?= "nokia800"
+#MACHINE ?= "fic-gta01"
+#MACHINE ?= "bootcdx86"
+#MACHINE ?= "cm-x270"
+#MACHINE ?= "em-x270"
+#MACHINE ?= "htcuniversal"
+#MACHINE ?= "mx31ads"
+#MACHINE ?= "mx31litekit"
+#MACHINE ?= "mx31phy"
+#MACHINE ?= "zylonite"
+#MACHINE ?= "igep0020"
+#MACHINE ?= "igep0030"
+
+DISTRO ?= "poky"
+# For bleeding edge / experimental / unstable package versions
+# DISTRO ?= "poky-bleeding"
+
+BBMASK = ""
+
+# EXTRA_IMAGE_FEATURES allows extra packages to be added to the generated images
+# (Some of these are automatically added to certain image types)
+# "dbg-pkgs" - add -dbg packages for all installed packages
+# (adds symbol information for debugging/profiling)
+# "dev-pkgs" - add -dev packages for all installed packages
+# (useful if you want to develop against libs in the image)
+# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
+# "tools-debug" - add debugging tools (gdb, strace)
+# "tools-profile" - add profiling tools (oprofile, exmap, lttng valgrind (x86 only))
+# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
+# "debug-tweaks" - make an image for suitable of development
+# e.g. ssh root access has a blank password
+# There are other application targets too, see meta/classes/poky-image.bbclass
+# and meta/packages/tasks/task-poky.bb for more details.
+
+EXTRA_IMAGE_FEATURES = "tools-debug tools-profile tools-testapps debug-tweaks"
+
+# The default IMAGE_FEATURES above are too large for the mx31phy and
+# c700/c750 machines which have limited space. The code below limits
+# the default features for those machines.
+EXTRA_IMAGE_FEATURES_c7x0 = "tools-testapps debug-tweaks"
+EXTRA_IMAGE_FEATURES_mx31phy = "debug-tweaks"
+EXTRA_IMAGE_FEATURES_mx31ads = "tools-testapps debug-tweaks"
+
+# A list of packaging systems used in generated images
+# The first package type listed will be used for rootfs generation
+# include 'package_deb' for debs
+# include 'package_ipk' for ipks
+#PACKAGE_CLASSES ?= "package_deb package_ipk"
+PACKAGE_CLASSES ?= "package_ipk"
+
+# A list of additional classes to use when building the system
+# include 'image-prelink' in order to prelink the filesystem image
+USER_CLASSES ?= "image-prelink"
+
+# POKYMODE controls the characteristics of the generated packages/images by
+# telling poky which type of toolchain to use.
+#
+# Options include several different EABI combinations and a compatibility
+# mode for the OABI mode poky previously used.
+#
+# The default is "eabi"
+# Use "oabi" for machines with kernels < 2.6.18 on ARM for example.
+# Use "external-MODE" to use the precompiled external toolchains where MODE
+# is the type of external toolchain to use e.g. eabi.
+# POKYMODE = "external-eabi"
+
+# Uncomment this to specify where BitBake should create its temporary files.
+# Note that a full build of everything in OpenEmbedded will take GigaBytes of hard
+# disk space, so make sure to free enough space. The default TMPDIR is
+# <build directory>/tmp
+#TMPDIR = "${POKYBASE}/build/tmp"
+
+
+# Uncomment this if you are using the Openedhand provided qemu deb - see README
+# ASSUME_PROVIDED += "qemu-native"
+
+# Comment this out if you don't have a 3.x gcc version available and wish
+# poky to build one for you. The 3.x gcc is required to build qemu-native.
+# ASSUME_PROVIDED += "gcc3-native"
+
+# Uncomment these two if you want BitBake to build images useful for debugging.
+# DEBUG_BUILD = "1"
+# INHIBIT_PACKAGE_STRIP = "1"
+
+# Uncomment these to build a package such that you can use gprof to profile it.
+# NOTE: This will only work with 'linux' targets, not
+# 'linux-uclibc', as uClibc doesn't provide the necessary
+# object files. Also, don't build glibc itself with these
+# flags, or it'll fail to build.
+#
+# PROFILE_OPTIMIZATION = "-pg"
+# SELECTED_OPTIMIZATION = "${PROFILE_OPTIMIZATION}"
+# LDFLAGS =+ "-pg"
+
+# Uncomment this if you want BitBake to emit debugging output
+# BBDEBUG = "yes"
+# Uncomment this if you want BitBake to emit the log if a build fails.
+BBINCLUDELOGS = "yes"
+
+# Set this if you wish to make pkgconfig libraries from your system available
+# for native builds. Combined with extra ASSUME_PROVIDEDs this can allow
+# native builds of applications like oprofileui-native (unsupported feature).
+#EXTRA_NATIVE_PKGCONFIG_PATH = ":/usr/lib/pkgconfig"
+#ASSUME_PROVIDED += "gtk+-native libglade-native"
+
+ENABLE_BINARY_LOCALE_GENERATION = "1"
+
+# The architecture to build SDK items for, by setting this you can build SDK
+# packages for architectures other than the host i.e. building i586 packages
+# on an x86_64 host.
+# Supported values are i586 and x86_64
+#SDKMACHINE ?= "i586"
+
+# Poky can try and fetch packaged-staging packages from a http, https or ftp
+# mirror. Set this variable to the root of a pstage directory on a server.
+#PSTAGE_MIRROR ?= "http://someserver.tld/share/pstage"
+
+# Set IMAGETEST to qemu if you want to build testcases and start
+# testing in qemu after do_rootfs.
+#IMAGETEST = "qemu"
+
+# By default testing will run the sanitytest suite. If you want to run other tests
+# (e.g. bat), list them here
+#TEST_SCEN = "sanitytest bat"