aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/qemu/qemu-helper-native_1.0.bb
diff options
context:
space:
mode:
authorJeff Dike <jdike@x86_64.user-mode-linux.org>2010-08-05 11:29:35 -0400
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-20 16:20:09 +0100
commite4bc3e36e455e7fca48ccc5431c6bb83f531fab6 (patch)
tree1482f2609a2ac08b14ee892cfed384664517b3e2 /meta/packages/qemu/qemu-helper-native_1.0.bb
parentd9aa25a3379c21a999bd39e78702f932ead7b840 (diff)
downloadopenembedded-core-e4bc3e36e455e7fca48ccc5431c6bb83f531fab6.tar.gz
tunctl: Added an tunctl which supports TUNSETGROUP
TUNSETGROUP is needed in order to preconfigure a set of tap devices that can be used by non-root users. The requirement is that the qemu users be members of whatever group the tap devices are assigned to. Include tunctl in the qemu-helper package, and add a -native version. Signed-off-by: Jeff Dike <jdike@linux.intel.com> Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta/packages/qemu/qemu-helper-native_1.0.bb')
-rw-r--r--meta/packages/qemu/qemu-helper-native_1.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/packages/qemu/qemu-helper-native_1.0.bb b/meta/packages/qemu/qemu-helper-native_1.0.bb
new file mode 100644
index 0000000000..19fb6f4ff7
--- /dev/null
+++ b/meta/packages/qemu/qemu-helper-native_1.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Qemu helper utilities from Poky"
+LICENSE = "GPLv2"
+RDEPENDS = "qemu-native"
+PR = "r0"
+
+FILESPATH = "${FILE_DIRNAME}/qemu-helper"
+
+SRC_URI = "file://tunctl.c"
+
+S = "${WORKDIR}"
+
+inherit native
+
+do_compile() {
+ ${CC} tunctl.c -o tunctl
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install tunctl ${D}${bindir}/
+}