summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/efivar/efivar_37.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-06-12 21:35:35 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-14 08:56:46 +0100
commit53fe0133432f62024850e87456292b044d1280ee (patch)
tree7fd0f3af738923d71e2252d2eaf96dc9579059bc /meta/recipes-bsp/efivar/efivar_37.bb
parent112deafd1c144d770b6ec0953911f2adc1cb30dd (diff)
downloadopenembedded-core-53fe0133432f62024850e87456292b044d1280ee.tar.gz
efivar: add
This was in meta-oe but EFI is sufficiently wide spread now that we need it in core. The recipe is based on the one in meta-oe but with several updates. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/efivar/efivar_37.bb')
-rw-r--r--meta/recipes-bsp/efivar/efivar_37.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-bsp/efivar/efivar_37.bb b/meta/recipes-bsp/efivar/efivar_37.bb
new file mode 100644
index 0000000000..c4254c70d9
--- /dev/null
+++ b/meta/recipes-bsp/efivar/efivar_37.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Tools to manipulate UEFI variables"
+DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility"
+HOMEPAGE = "https://github.com/rhboot/efivar"
+
+LICENSE = "LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393"
+
+COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
+
+SRC_URI = "git://github.com/rhinstaller/efivar.git \
+ file://no-werror.patch"
+SRCREV = "c1d6b10e1ed4ba2be07f385eae5bceb694478a10"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig
+
+export CCLD_FOR_BUILD = "${BUILD_CCLD}"
+
+# Upstream uses --add-needed in gcc.specs which gold doesn't support, so
+# enforce BFD.
+LDFLAGS += "-fuse-ld=bfd"
+
+do_compile_prepend() {
+ # Remove when https://github.com/rhboot/efivar/issues/130 is fixed
+ oe_runmake CFLAGS="${BUILD_CFLAGS}" -C src makeguids
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+BBCLASSEXTEND = "native"
+
+RRECOMMENDS_${PN}_class-target = "kernel-module-efivarfs"
+
+CLEANBROKEN = "1"