aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/v86d
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-02-15 23:17:51 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-01 12:57:21 +0000
commit8d4256b2c9f782368a16c1458e04ed61fa82691a (patch)
treede2d868a2cfdd5c45a1c87cadba39a5597837a06 /meta/recipes-bsp/v86d
parenta1ce9da1feb028bbfd861d075bc3b6fbe3300147 (diff)
downloadopenembedded-core-8d4256b2c9f782368a16c1458e04ed61fa82691a.tar.gz
v86d: compile against userspace safe kernel headers
v86d was building directly against the staged kernel in the target sysroot. This has been fine in the past, but with recent (3.7) changes to user headers into the "uapi" include structure, there are no longer Without the preprocesor protection, v86d fails to build against any kernel with uapi header files. v86d doesn't actually need the whole kernel tree, the exported headers are enough to build a working binary. This change sets the v86d variable to ${STAGING_DIR_HOST}/usr, and once the v86d build adds "include" to the end of KDIR, we have a valid include path to the target sysroot headers. This also works for pre-uapi kernel headers, so the change is safe for most (if not all) kernel's with properly exported headers. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-bsp/v86d')
-rw-r--r--meta/recipes-bsp/v86d/v86d_0.1.10.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-bsp/v86d/v86d_0.1.10.bb b/meta/recipes-bsp/v86d/v86d_0.1.10.bb
index 51829a3edb..2dbfbb579a 100644
--- a/meta/recipes-bsp/v86d/v86d_0.1.10.bb
+++ b/meta/recipes-bsp/v86d/v86d_0.1.10.bb
@@ -27,7 +27,7 @@ do_configure () {
}
do_compile () {
- KDIR="${STAGING_KERNEL_DIR}" make
+ KDIR="${STAGING_DIR_HOST}/usr" make
}
do_install () {