summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorXulin Sun <xulin.sun@windriver.com>2019-01-29 15:31:22 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-31 23:04:50 +0000
commita4032f3cc5de451f0e97eca1f0cbe4a310e1560b (patch)
tree08f4842ee3ce104fdc7e0bf37e6a138af2f0bd3c /meta/recipes-connectivity
parent3ea08f4b24f8a49c3d5039b62b39d6419cfe234c (diff)
downloadopenembedded-core-a4032f3cc5de451f0e97eca1f0cbe4a310e1560b.tar.gz
openssl: fix multilib file install conflicts
To avoid issue like below if run "bitbake lib32-core-image-minimal" with series userspace packages(LAMP,krb5...) added. Add multilib_script support for openssl's c_rehash which is a perl script. Error: Transaction check error: file /usr/bin/c_rehash conflicts between attempted installs of lib32-openssl-bin-1.1.1-r0.armv7at2hf_neon and openssl-bin-1.1.1-r0.aarch64 Signed-off-by: Xulin Sun <xulin.sun@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.1.1a.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.1.1a.bb b/meta/recipes-connectivity/openssl/openssl_1.1.1a.bb
index 5c4e69cfb7..6676614bc0 100644
--- a/meta/recipes-connectivity/openssl/openssl_1.1.1a.bb
+++ b/meta/recipes-connectivity/openssl/openssl_1.1.1a.bb
@@ -206,3 +206,7 @@ RREPLACES_openssl-conf = "openssl10-conf"
RCONFLICTS_openssl-conf = "openssl10-conf"
BBCLASSEXTEND = "native nativesdk"
+
+inherit multilib_script
+
+MULTILIB_SCRIPTS = "${PN}-bin:${bindir}/c_rehash"