summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2023-12-31 13:27:50 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-01-18 10:15:32 +0000
commit451363438d38bd4552d5bcec4a92332f5819a5d4 (patch)
tree68fe42e2dfe5d3cd1fe8996b775bfc89cf8909f2 /meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
parent0ffff2c1f80a9b79b133d787764bab164d9abd70 (diff)
downloadopenembedded-core-451363438d38bd4552d5bcec4a92332f5819a5d4.tar.gz
classes/recipes: Switch to use inherit_defer
Now that bitbake supports the use of inherit_defer, switch all conditional (variable based) inherits to use this instead. This leads to more a more deterministic user experience since there is no longer an immediate expansion and later changes to the variables in question (e.g. a bbappend) are accounted for. This patch tries to ensure the behaviour before/after remains as unchanged as it reasonably can, e.g. by always inherting populate_sdk_base. native and nativesdk continue to need to be inherited last, hence being used with inherit_defer in a handful of very specific cases. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb')
-rw-r--r--meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb b/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
index 11e31dcba3..c1d3c25060 100644
--- a/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
+++ b/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
@@ -4,7 +4,8 @@
SUMMARY = "Host packages for the standalone SDK or external toolchain"
-inherit packagegroup nativesdk
+inherit packagegroup
+inherit_defer nativesdk
PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"