aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/apt/apt_1.2.12.bb
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linux.intel.com>2016-07-29 14:53:01 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-04 15:05:46 +0100
commit369a7f7232aa8406b63376f7888896fe90f9ce40 (patch)
treecea67cea08309eaec099bda1baa9829a019685a8 /meta/recipes-devtools/apt/apt_1.2.12.bb
parent0d79e7b4373053a7f20f18ed962c5a17a969e57e (diff)
downloadopenembedded-core-369a7f7232aa8406b63376f7888896fe90f9ce40.tar.gz
apt: Upgrade to 1.2.12
Test was made building core-image-sato with package_deb on qemux86 and qemuarm then run for two of them testimage and install packages with apt-get using PACKAGE_FEED_URI's configuration. Now apt support drop priviligies for install packages using a sandbox with _apt user, the useradd class was inherit and configured to install _apt user and group. Rebased patches: - 0001-Revert-always-run-dpkg-configure-a-at-the-end-of-our.patch - 0001-fix-the-gcc-version-check.patch - 0001-remove-Wsuggest-attribute-from-CFLAGS.patch - disable-test.patch - no-curl.patch Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/apt/apt_1.2.12.bb')
-rw-r--r--meta/recipes-devtools/apt/apt_1.2.12.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/apt/apt_1.2.12.bb b/meta/recipes-devtools/apt/apt_1.2.12.bb
new file mode 100644
index 0000000000..85c0d56159
--- /dev/null
+++ b/meta/recipes-devtools/apt/apt_1.2.12.bb
@@ -0,0 +1,19 @@
+DEPENDS = "curl db zlib"
+RDEPENDS_${PN} = "dpkg bash debianutils"
+require apt.inc
+
+require apt-package.inc
+
+PACKAGECONFIG ??= "lzma"
+PACKAGECONFIG[lzma] = "ac_cv_lib_lzma_lzma_easy_encoder=yes,ac_cv_lib_lzma_lzma_easy_encoder=no,xz"
+PACKAGECONFIG[bz2] = "ac_cv_lib_bz2_BZ2_bzopen=yes,ac_cv_lib_bz2_BZ2_bzopen=no,bzip2"
+
+FILES_${PN} += "${bindir}/apt-key"
+apt-manpages += "doc/apt-key.8"
+
+do_install_append() {
+ #Write the correct apt-architecture to apt.conf
+ APT_CONF=${D}/etc/apt/apt.conf
+ echo 'APT::Architecture "${DPKG_ARCH}";' > ${APT_CONF}
+ oe_libinstall -so -C bin libapt-private ${D}${libdir}/
+}