summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/autogen
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2013-06-19 13:34:57 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-19 09:09:24 +0100
commit92c7a0bec3f3c9fec04a6019aa9cee395ba5a9ab (patch)
tree229437c17053fd4518b195ae964eddf716312a00 /meta/recipes-devtools/autogen
parent871ae7a6453b3b66610fd8bbaa770c92be850e19 (diff)
downloadopenembedded-core-92c7a0bec3f3c9fec04a6019aa9cee395ba5a9ab.tar.gz
autogen-native: fix build failure on overloaded hosts
On some overloaded hosts, shell commands of autogen may can not finish in 5 secs. This has caused many build failures, so increase the timeout limit to fix this. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/autogen')
-rw-r--r--meta/recipes-devtools/autogen/autogen-native_5.17.4.bb3
-rw-r--r--meta/recipes-devtools/autogen/files/increase-timeout-limit.patch33
2 files changed, 35 insertions, 1 deletions
diff --git a/meta/recipes-devtools/autogen/autogen-native_5.17.4.bb b/meta/recipes-devtools/autogen/autogen-native_5.17.4.bb
index e5234c2909..230c3a798c 100644
--- a/meta/recipes-devtools/autogen/autogen-native_5.17.4.bb
+++ b/meta/recipes-devtools/autogen/autogen-native_5.17.4.bb
@@ -9,7 +9,8 @@ LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
SRC_URI = "${GNU_MIRROR}/autogen/rel${PV}/autogen-${PV}.tar.gz \
- file://guile.patch"
+ file://guile.patch \
+ file://increase-timeout-limit.patch"
SRC_URI[md5sum] = "09f074cba57610bf4ef1147e01c8ae90"
SRC_URI[sha256sum] = "cd2585f4794d0e9d7f2cb0b9af4f2bd429946e718473edf1cf8c49f081ca71ed"
diff --git a/meta/recipes-devtools/autogen/files/increase-timeout-limit.patch b/meta/recipes-devtools/autogen/files/increase-timeout-limit.patch
new file mode 100644
index 0000000000..3d4c1d604e
--- /dev/null
+++ b/meta/recipes-devtools/autogen/files/increase-timeout-limit.patch
@@ -0,0 +1,33 @@
+Subject: [PATCH] autogen: increase timeout limit for shell commands
+
+On some overloaded hosts, shell commands of autogen may can not
+finish in 5 secs. This has caused many build failures, so increase
+the timeout limit to fix this.
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Xin Ouyang <Xin.Ouyang@windriver.com>
+---
+ configure.ac | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 0af7c18..5544f59 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -175,9 +175,9 @@ config_end_time=`date +%s 2>/dev/null`
+ time_delta=`expr ${config_end_time} - ${config_start_time} 2>/dev/null`
+
+ if test -z "${time_delta}"
+-then time_delta=10
+-elif test ${time_delta} -lt 5
+-then time_delta=5 ; fi
++then time_delta=60
++elif test ${time_delta} -lt 30
++then time_delta=30 ; fi
+
+ AG_TIMEOUT=${time_delta}
+ ]
+--
+1.7.9.5
+