summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bison
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-03-14 21:29:47 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-03-21 22:38:19 +0000
commit1b8451aa4ba2b42b1eb1dc938fa3397d3434839a (patch)
tree36d6b95540bc429e72ac5e3d373935cca6c31ea5 /meta/recipes-devtools/bison
parentb073317d5ea71217443624e5dc3b55831bb56018 (diff)
downloadopenembedded-core-1b8451aa4ba2b42b1eb1dc938fa3397d3434839a.tar.gz
bison: Reset load average settings if specified in environment
In some cases, we run into parallel build failures where BUILT_SOURCES is skipped, as a result required header files are not generated and the build fails with missing header errors like ../bison-3.5.2/lib/uniwidth/width.c:21:10: fatal error: uniwidth.h: No such file or directory #include "uniwidth.h" ^~~~~~~~~~~~ compilation terminated. BUILT_SOURCES should be built automatically with `make all` [1] therefore ensure that make is invoked with `all` target bison-native parallel build fails when -l<n> is passed globally from build environment, errors like below due to race starts to show up Therefore removes a previous load limit if set [1] https://www.gnu.org/software/automake/manual/html_node/Built-Sources-Example.html#Built-Sources-Example Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/bison')
-rw-r--r--meta/recipes-devtools/bison/bison_3.5.3.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison_3.5.3.bb b/meta/recipes-devtools/bison/bison_3.5.3.bb
index 09e4b18f9e..27e09434f8 100644
--- a/meta/recipes-devtools/bison/bison_3.5.3.bb
+++ b/meta/recipes-devtools/bison/bison_3.5.3.bb
@@ -18,6 +18,12 @@ SRC_URI[sha256sum] = "2bf85b5f88a5f2fa8069aed2a2dfc3a9f8d15a97e59c713e3906e5fdd9
# No point in hardcoding path to m4, just use PATH
EXTRA_OECONF += "M4=m4"
+# Reset any loadavg set via environment, it breaks parallel build
+# | ../bison-3.5.2/lib/uniwidth/width.c:21:10: fatal error: uniwidth.h: No such file or directory
+# | #include "uniwidth.h"
+# | ^~~~~~~~~~~~
+EXTRA_OEMAKE_append = " -l"
+
inherit autotools gettext texinfo
# The automatic m4 path detection gets confused, so force the right value