summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bison
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-19 13:03:32 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-19 14:06:01 +0100
commit4b132d440ed97053dbef5a4deeb39e37e1167def (patch)
treef677c255447d52f39043c0f0ba1aa3481fead2a9 /meta/recipes-devtools/bison
parentc3e086805649bbe782ac76670acf5858536d8801 (diff)
downloadopenembedded-core-4b132d440ed97053dbef5a4deeb39e37e1167def.tar.gz
bison: Fix gplv2 version to work with recent gettext
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/bison')
-rw-r--r--meta/recipes-devtools/bison/bison_2.3.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison_2.3.bb b/meta/recipes-devtools/bison/bison_2.3.bb
index 388476b462..86edf3ee1d 100644
--- a/meta/recipes-devtools/bison/bison_2.3.bb
+++ b/meta/recipes-devtools/bison/bison_2.3.bb
@@ -25,6 +25,11 @@ SRC_URI_virtclass-native = "${BASE_SRC_URI}"
inherit autotools gettext
acpaths = "-I ${S}/m4"
+do_configure_prepend () {
+ rm -f ${S}/m4/*gl.m4
+ cp ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/runtime-po/
+}
+
do_install_append_virtclass-native() {
create_wrapper ${D}/${bindir}/bison \
M4=${STAGING_BINDIR_NATIVE}/m4 \