aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bootchart2
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-06-02 12:25:53 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-02 11:45:25 +0100
commitc4829e96272376c61d8645df75c4b946f37b461c (patch)
treefcdf4bc5803df3e1b53ec249606c9ac81dde2d85 /meta/recipes-devtools/bootchart2
parentbfd62071befd0f20597cf9c62c281fb6e815bd2e (diff)
downloadopenembedded-core-c4829e96272376c61d8645df75c4b946f37b461c.tar.gz
bootchart2: move to Python 3
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/bootchart2')
-rw-r--r--meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb16
1 files changed, 6 insertions, 10 deletions
diff --git a/meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb b/meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb
index 86c614a63b..d0555c3edb 100644
--- a/meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb
+++ b/meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb
@@ -99,7 +99,7 @@ SRCREV = "48e0071048564c6af75ab969e842d6dec808da09"
inherit systemd
inherit update-rc.d
-inherit pythonnative
+inherit python3native
# The only reason to build bootchart2-native is for a native pybootchartgui.
BBCLASSEXTEND = "native"
@@ -110,13 +110,6 @@ UPDATERCPN = "bootchartd-stop-initscript"
INITSCRIPT_NAME = "bootchartd_stop.sh"
INITSCRIPT_PARAMS = "start 99 2 3 4 5 ."
-# We want native pybootchartgui to execute with the correct Python interpeter.
-do_compile_append_class-native () {
- echo "#! ${PYTHON}" | cat - ${S}/pybootchartgui.py > ${WORKDIR}/temp_pybootchartgui
- mv ${WORKDIR}/temp_pybootchartgui ${S}/pybootchartgui.py
- chmod +x ${S}/pybootchartgui
-}
-
do_compile_prepend () {
export PY_LIBDIR="${libdir}/${PYTHON_DIR}"
export BINDIR="${bindir}"
@@ -135,14 +128,17 @@ do_install () {
install -m 0755 ${WORKDIR}/bootchartd_stop.sh ${D}${sysconfdir}/init.d
echo 'EXIT_PROC="$EXIT_PROC matchbox-window-manager"' >> ${D}${sysconfdir}/bootchartd.conf
+
+ # Use python 3 instead of python 2
+ sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${bindir}/pybootchartgui
}
PACKAGES =+ "pybootchartgui"
FILES_pybootchartgui += "${libdir}/python*/site-packages/pybootchartgui ${bindir}/pybootchartgui"
-RDEPENDS_pybootchartgui = "python-pycairo python-compression python-image python-textutils python-shell python-compression python-codecs"
+RDEPENDS_pybootchartgui = "python3-pycairo python3-compression python3-image python3-textutils python3-shell python3-compression python3-codecs"
RDEPENDS_${PN}_class-target += "${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'sysvinit-pidof', 'procps', d)}"
RDEPENDS_${PN}_class-target += "lsb"
-DEPENDS_append_class-native = " python-pycairo-native"
+DEPENDS_append_class-native = " python3-pycairo-native"
PACKAGES =+ "bootchartd-stop-initscript"
FILES_bootchartd-stop-initscript += "${sysconfdir}/init.d ${sysconfdir}/rc*.d"