summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake-native_3.10.1.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-01-17 13:59:33 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-19 12:18:04 +0000
commit9e58926f1cea9d5cb18cb923855d1ae98f88a8ac (patch)
tree6f53cf29a37efc697cdc99bc12fa81caf522af06 /meta/recipes-devtools/cmake/cmake-native_3.10.1.bb
parentb77bb7afe5131d9157be9dfebda4d4185a98a820 (diff)
downloadopenembedded-core-9e58926f1cea9d5cb18cb923855d1ae98f88a8ac.tar.gz
cmake: upgrade 3.9.5 -> 3.10.1
The 3.10.1 version has been in Dec 13, 2017, and has a great set of features and improvements since the last upgrade. The release notes of 3.10 release is available at: https://cmake.org/cmake/help/v3.10/release/3.10.html Patches updates: - cmake-Prevent-the-detection-of-Qt5.patch: so it replaces the sed command calls inside the cmake.inc - 0001-FindCUDA-Use-find_program-if-find_host_program-is-no.patch: merged upstream, so it has been removed. - support-oe-qt4-tools-names.patch: rebased. License-checksum-change: added new contributors Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake-native_3.10.1.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.10.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.10.1.bb b/meta/recipes-devtools/cmake/cmake-native_3.10.1.bb
new file mode 100644
index 0000000000..e55e8b1cf6
--- /dev/null
+++ b/meta/recipes-devtools/cmake/cmake-native_3.10.1.bb
@@ -0,0 +1,38 @@
+require cmake.inc
+inherit native
+
+DEPENDS += "bzip2-replacement-native expat-native xz-native zlib-native curl-native"
+
+SRC_URI += "\
+ file://cmlibarchive-disable-ext2fs.patch \
+"
+
+B = "${WORKDIR}/build"
+do_configure[cleandirs] = "${B}"
+
+# Disable ccmake since we don't depend on ncurses
+CMAKE_EXTRACONF = "\
+ -DCMAKE_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
+ -DBUILD_CursesDialog=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARIES=1 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_JSONCPP=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_LIBARCHIVE=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_LIBUV=0 \
+ -DCMAKE_USE_SYSTEM_LIBRARY_LIBRHASH=0 \
+ -DENABLE_ACL=0 -DHAVE_ACL_LIBACL_H=0 \
+ -DHAVE_SYS_ACL_H=0 \
+"
+
+do_configure () {
+ ${S}/configure --verbose --prefix=${prefix} -- ${CMAKE_EXTRACONF}
+}
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+do_compile[progress] = "percent"