aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/docbook-sgml-dtd
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-03-12 05:58:47 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-17 14:01:07 +0000
commit87df114982db7a94fce8622b15458bbe2d2ddacc (patch)
tree6468ddab649deb88fd83f3ebc48b6f1b053cc5fb /meta/recipes-devtools/docbook-sgml-dtd
parentf09d2583894be0a4069600381046bec5e7f0277b (diff)
downloadopenembedded-core-87df114982db7a94fce8622b15458bbe2d2ddacc.tar.gz
docbook-sgml-dtd-native: remove catalog file when do_clean
The docbook_sgml_dtd_sstate_postinst adds catalog file to /etc/sgml/sgml-docbook.cat and sgml-docbook.bak, but the do_clean would not remove the file, which would cause unexpected errors since we have multiple versions of docbook-sgml-dtd: docbook-sgml-dtd-3.1-native_3.1.bb docbook-sgml-dtd-4.1-native_4.1.bb docbook-sgml-dtd-4.5-native.bb If we run: $ bitbake docbook-sgml-dtd-4.1-native $ bitbake docbook-sgml-dtd-4.1-native -ccleansstate && bitbake docbook-sgml-dtd-3.1-native $ bitbake docbook-utils-native We would get this error: jade: cannot open "/path/to/etc/sgml/sgml-docbook-dtd-4.1.cat" (No such file or directory) make[2]: *** [sgmldiff.html] Error 1 Remove the catalog entry when do_clean will fix the problem. [YOCTO #5949] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/docbook-sgml-dtd')
-rw-r--r--meta/recipes-devtools/docbook-sgml-dtd/docbook-sgml-dtd-native.inc12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta/recipes-devtools/docbook-sgml-dtd/docbook-sgml-dtd-native.inc b/meta/recipes-devtools/docbook-sgml-dtd/docbook-sgml-dtd-native.inc
index 1b357b5368..b2381bd7d1 100644
--- a/meta/recipes-devtools/docbook-sgml-dtd/docbook-sgml-dtd-native.inc
+++ b/meta/recipes-devtools/docbook-sgml-dtd/docbook-sgml-dtd-native.inc
@@ -58,3 +58,15 @@ docbook_sgml_dtd_sysroot_preprocess () {
install -m 755 ${STAGING_BINDIR_NATIVE}/install-catalog ${SYSROOT_DESTDIR}${bindir_crossscripts}/install-catalog-docbook-sgml-dtd-${DTD_VERSION}
}
+CLEANFUNCS += "docbook_sgml_dtd_sstate_clean"
+
+docbook_sgml_dtd_sstate_clean () {
+ # Ensure that the catalog file sgml-docbook.cat is properly
+ # updated when the package is removed from sstate cache.
+ if [ -f ${sysconfdir}/sgml/sgml-docbook.bak ]; then
+ sed -i '/'"\/sgml\/sgml-docbook-dtd-${DTD_VERSION}.cat"'/d' \
+ ${sysconfdir}/sgml/sgml-docbook.bak
+ sed -i '/'"\/sgml\/sgml-docbook-dtd-${DTD_VERSION}.cat"'/d' \
+ ${sysconfdir}/sgml/sgml-docbook.cat
+ fi
+}