summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/docbook-utils
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-03-25 11:00:56 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-25 20:51:15 +0000
commitd60aec3f5b319f4583fa72a8357b9ddd3be62b1a (patch)
tree4624c6994e8c3c70edf923e37d931f26170e2655 /meta/recipes-devtools/docbook-utils
parent4e1ea0e22cf5310dbe18b5427a91d86cc4a136fe (diff)
downloadopenembedded-core-d60aec3f5b319f4583fa72a8357b9ddd3be62b1a.tar.gz
docbook-utils-native: Unbreak the build after source and build dir split
docbook-utils-native started to install frontends and backends in wrong locations after this change. The absolute build and source directories were being created in install locations and the recipes using docbook-utils-native were complaining like dbus-java is saying | jw: There is no frontend called "/b/kraj/jlinux-next/poky/build/tmp-eglibc/sysroots/x86_64-linux/usr/share/sgml/docbook/utils-0.6.14/frontends/docbook". | make: *** [CreateInterface.1] Error 2 | ERROR: oe_runmake failed Rightly so because now they are installed under /b/kraj/jlinux-next/poky/build/tmp-eglibc/sysroots/x86_64-linux/usr/share/sgml/docbook/utils-0.6.14/b/kraj/jlinux-next/poky/build/tmp-eglibc/work/x86_64-linux/docbook-utils-native/0.6.14-r3/ This patch fixes the install to be like it was but consider the build and sourcedir split. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/docbook-utils')
-rw-r--r--meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb17
1 files changed, 11 insertions, 6 deletions
diff --git a/meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb b/meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb
index 78034dd987..c3a5f3b421 100644
--- a/meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb
+++ b/meta/recipes-devtools/docbook-utils/docbook-utils-native_0.6.14.bb
@@ -45,14 +45,19 @@ do_install() {
done
install -m 0755 ${B}/bin/jw ${D}${bindir}/
- for i in ${S}/backends/dvi ${S}/backends/html ${B}/backends/man \
- ${S}/backends/pdf ${S}/backends/ps ${S}/backends/rtf ${S}/backends/tex \
- ${B}/backends/texi ${S}/backends/txt ${B}/frontends/docbook \
- ${S}/helpers/docbook2man-spec.pl ${S}/helpers/docbook2texi-spec.pl \
- ${S}/docbook-utils.dsl
+ for i in backends/dvi backends/html \
+ backends/pdf backends/ps backends/rtf backends/tex \
+ backends/txt \
+ helpers/docbook2man-spec.pl helpers/docbook2texi-spec.pl \
+ docbook-utils.dsl
do
install -d ${D}${datadir}/sgml/docbook/utils-${PV}/`dirname $i`
- install $i ${D}${datadir}/sgml/docbook/utils-${PV}/$i
+ install ${S}/$i ${D}${datadir}/sgml/docbook/utils-${PV}/$i
+ done
+ for i in backends/man backends/texi frontends/docbook
+ do
+ install -d ${D}${datadir}/sgml/docbook/utils-${PV}/`dirname $i`
+ install ${B}/$i ${D}${datadir}/sgml/docbook/utils-${PV}/$i
done
}