summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-11-15 12:58:40 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-16 17:27:09 +0000
commit57f4a5ca47e8e343ae30a07b922be0c177280b2f (patch)
tree8cd0c3e7ddadcf064b7ef6f3f583eb79773ee35f /meta/recipes-devtools/file
parent3094a844f1ceb77153ac1a733623e6aca770b64b (diff)
downloadopenembedded-core-57f4a5ca47e8e343ae30a07b922be0c177280b2f.tar.gz
file: update to 5.09
Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/file')
-rw-r--r--meta/recipes-devtools/file/file/fix_version_check.patch21
-rw-r--r--meta/recipes-devtools/file/file_5.09.bb (renamed from meta/recipes-devtools/file/file_5.04.bb)9
2 files changed, 25 insertions, 5 deletions
diff --git a/meta/recipes-devtools/file/file/fix_version_check.patch b/meta/recipes-devtools/file/file/fix_version_check.patch
new file mode 100644
index 0000000000..bd24ccb49f
--- /dev/null
+++ b/meta/recipes-devtools/file/file/fix_version_check.patch
@@ -0,0 +1,21 @@
+Since we are cross-compiling and need to have a cover script this
+version check sees "file.real-5.09" not "file-5.09", so fix the
+sed.
+
+Upstream-Status: Inapproriate [build-specific]
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: file-5.09/magic/Makefile.am
+===================================================================
+--- file-5.09.orig/magic/Makefile.am
++++ file-5.09/magic/Makefile.am
+@@ -260,7 +260,7 @@ ${MAGIC}: $(EXTRA_DIST) $(FILE_COMPILE_D
+ @(if expr "${FILE_COMPILE}" : '.*/.*' > /dev/null; then \
+ echo "Using ${FILE_COMPILE} to generate ${MAGIC}" > /dev/null; \
+ else \
+- v=$$(file --version | sed -e s/file-// -e q); \
++ v=$$(file --version | sed -e s/file.real-// -e q); \
+ if [ "$$v" != "${PACKAGE_VERSION}" ]; then \
+ echo "Cannot use the installed version of file ($$v) to"; \
+ echo "cross-compile file ${PACKAGE_VERSION}"; \
diff --git a/meta/recipes-devtools/file/file_5.04.bb b/meta/recipes-devtools/file/file_5.09.bb
index 1f9c78eb7b..9b2f3a42af 100644
--- a/meta/recipes-devtools/file/file_5.04.bb
+++ b/meta/recipes-devtools/file/file_5.09.bb
@@ -10,16 +10,15 @@ LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03
DEPENDS = "zlib file-native"
DEPENDS_virtclass-native = "zlib-native"
-PR = "r2"
+PR = "r0"
SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
- file://stringb-compat.patch \
- file://ge-le.patch \
+ file://fix_version_check.patch \
file://dump \
file://filesystems"
-SRC_URI[md5sum] = "accade81ff1cc774904b47c72c8aeea0"
-SRC_URI[sha256sum] = "4c9e6e7994e74cb3386374ae91b055d26ac96b9d3e82fd157ae2d62e87a4260c"
+SRC_URI[md5sum] = "6fd7cd6c4281e68fe9ec6644ce0fac6f"
+SRC_URI[sha256sum] = "bde1c9830ee6c234871778faae8277fdcf775fbb16dea63c8251e24b7c2f869c"
inherit autotools