aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc/gcc-cross_4.8.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-03-26 19:14:43 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-22 14:43:46 +0100
commitc850415a1bdbb9268114d90fd0fc4cb3479de9c5 (patch)
tree2becbac776d6b8886e864322c080cb40fd00d9d8 /meta/recipes-devtools/gcc/gcc-cross_4.8.bb
parent188862de64bc2b61f8510082c8a6e5929d2b79d1 (diff)
downloadopenembedded-core-c850415a1bdbb9268114d90fd0fc4cb3479de9c5.tar.gz
gcc-4.8: Add recipes
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc-cross_4.8.bb')
-rw-r--r--meta/recipes-devtools/gcc/gcc-cross_4.8.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-cross_4.8.bb b/meta/recipes-devtools/gcc/gcc-cross_4.8.bb
new file mode 100644
index 0000000000..d60523513f
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc-cross_4.8.bb
@@ -0,0 +1,14 @@
+require recipes-devtools/gcc/gcc-${PV}.inc
+require gcc-cross4.inc
+
+EXTRA_OECONF += "--disable-libunwind-exceptions \
+ --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} \
+ --with-system-zlib "
+
+EXTRA_OECONF_PATHS = " \
+ --with-gxx-include-dir=${STAGING_DIR_TARGET}${target_includedir}/c++ \
+ --with-sysroot=${STAGING_DIR_TARGET} \
+ --with-build-sysroot=${STAGING_DIR_TARGET}"
+
+
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"