summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc/gcc_6.2.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-08-16 11:50:35 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-19 10:23:31 +0100
commit41ce4b438795108025c79cd3eec067367d53623e (patch)
tree105d374e16fcc70ce72757713087b131adb4544b /meta/recipes-devtools/gcc/gcc_6.2.bb
parentcd8b64b0a236b27e5383e2394de65b9bfd4b6677 (diff)
downloadopenembedded-core-41ce4b438795108025c79cd3eec067367d53623e.tar.gz
gcc: Upgrade to 6.2 RC1
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc_6.2.bb')
-rw-r--r--meta/recipes-devtools/gcc/gcc_6.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc_6.2.bb b/meta/recipes-devtools/gcc/gcc_6.2.bb
new file mode 100644
index 0000000000..b0a523cae2
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc_6.2.bb
@@ -0,0 +1,15 @@
+require recipes-devtools/gcc/gcc-${PV}.inc
+require gcc-target.inc
+
+# Building with thumb enabled on armv4t fails with
+# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7438:(.text.unlikely+0x2fa): relocation truncated to fit: R_ARM_THM_CALL against symbol `fancy_abort(char const*, int, char const*)' defined in .glue_7 section in linker stubs
+# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output
+ARM_INSTRUCTION_SET_armv4 = "arm"
+
+do_configure_prepend() {
+ # Easiest way to stop bad RPATHs getting into the library since we have a
+ # broken libtool here
+ sed -i -e 's/hardcode_into_libs=yes/hardcode_into_libs=no/' ${S}/libcc1/configure
+}
+
+BBCLASSEXTEND = "nativesdk"