aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gdb/gdb_7.6.2.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2014-02-06 17:29:22 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-08 21:03:26 +0000
commitbfeb7ce8b525890c150f0b1cc2c5df089aa4b052 (patch)
tree1c0a4b7b53eaa070b65d5abdd8ec69c238e97ec5 /meta/recipes-devtools/gdb/gdb_7.6.2.bb
parent5bcf6a03c83cb91793d891f1e860c200eaa68be3 (diff)
downloadopenembedded-core-bfeb7ce8b525890c150f0b1cc2c5df089aa4b052.tar.gz
gdb: upgrade to 7.6.2
Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_7.6.2.bb')
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.6.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.6.2.bb b/meta/recipes-devtools/gdb/gdb_7.6.2.bb
new file mode 100644
index 0000000000..e86447121b
--- /dev/null
+++ b/meta/recipes-devtools/gdb/gdb_7.6.2.bb
@@ -0,0 +1,23 @@
+require gdb.inc
+require gdb-${PV}.inc
+
+inherit python-dir
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,python"
+
+do_configure_prepend() {
+ if [ -n "${@base_contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then
+ cat > ${WORKDIR}/python << EOF
+#!/bin/sh
+case "\$2" in
+ --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;;
+ --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;;
+ --exec-prefix) echo "${exec_prefix}" ;;
+ *) exit 1 ;;
+esac
+exit 0
+EOF
+ chmod +x ${WORKDIR}/python
+ fi
+}