summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gdb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-07-29 15:28:01 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-04 15:05:46 +0100
commit60de4d6c717c6a5131b02de29234d53a6ca1b993 (patch)
tree522349907032c011f9acf0d297eac1bfbc54a37e /meta/recipes-devtools/gdb
parente6e228b36f2603540d33b06f515aed7d2f5b8a6d (diff)
downloadopenembedded-core-60de4d6c717c6a5131b02de29234d53a6ca1b993.tar.gz
gdb: Cache gnu gettext config vars for musl builds
intl is used in gdb as well and we run the configure for it when running do compile. So we need to insert these caching of variables to extra oe_make Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/gdb')
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.11.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.11.bb b/meta/recipes-devtools/gdb/gdb_7.11.bb
index f02e6431dd..57cffc9983 100644
--- a/meta/recipes-devtools/gdb/gdb_7.11.bb
+++ b/meta/recipes-devtools/gdb/gdb_7.11.bb
@@ -3,6 +3,11 @@ require gdb-${PV}.inc
inherit python3-dir
+EXTRA_OEMAKE_append_libc-musl = "\
+ gt_cv_func_gnugettext1_libc=yes \
+ gt_cv_func_gnugettext2_libc=yes \
+ "
+
do_configure_prepend() {
if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then
cat > ${WORKDIR}/python << EOF