summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/git
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2011-06-10 15:25:19 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-14 13:23:48 +0100
commit2d17a75510c3f731f71def9460210b3e7354b6ca (patch)
tree0fcfe8690e0576136bc241f4c2c7c54cfc393a61 /meta/recipes-devtools/git
parent576c87349a72a94357014ff29f55db692903ed80 (diff)
downloadopenembedded-core-2d17a75510c3f731f71def9460210b3e7354b6ca.tar.gz
git: restore the dependency on perl-native
[YOCTO #1155] I thought git-native could depend on perl-native-runtime and tests on Ubuntu 9.04/10.10 and Fedora 13 show it could buid fine (looks these distros install perl-ExtUtils-MakeMaker by default). However Joshua reported on Fedora 15 i686 host, git-native can't build unless he manually installed perl-ExtUtils-MakeMaker to the host. This makes me think we may as well make git-native depend on perl-native. Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Diffstat (limited to 'meta/recipes-devtools/git')
-rw-r--r--meta/recipes-devtools/git/git.inc6
-rw-r--r--meta/recipes-devtools/git/git_1.7.5.1.bb2
2 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/git/git.inc b/meta/recipes-devtools/git/git.inc
index c884f9ccc1..5d778805ad 100644
--- a/meta/recipes-devtools/git/git.inc
+++ b/meta/recipes-devtools/git/git.inc
@@ -1,16 +1,16 @@
DESCRIPTION = "The git revision control system used by the Linux kernel developers"
SECTION = "console/utils"
LICENSE = "GPLv2"
-DEPENDS = "perl-native openssl curl zlib expat"
+DEPENDS = "openssl curl zlib expat"
SRC_URI = "${KERNELORG_MIRROR}/software/scm/git/git-${PV}.tar.bz2 "
S = "${WORKDIR}/git-${PV}"
LIC_FILES_CHKSUM = "file://COPYING;md5=7c0d7ef03a7eb04ce795b0f60e68e7e1"
-EXTRA_OECONF = "--with-perl=${STAGING_BINDIR_NATIVE}/perl --without-tcltk"
+EXTRA_OECONF = "--with-perl=${STAGING_BINDIR_NATIVE}/perl-native/perl --without-tcltk"
-inherit autotools
+inherit autotools perlnative
do_install () {
oe_runmake install DESTDIR="${D}" bindir=${bindir} \
diff --git a/meta/recipes-devtools/git/git_1.7.5.1.bb b/meta/recipes-devtools/git/git_1.7.5.1.bb
index bfdbf62954..04d1d5602c 100644
--- a/meta/recipes-devtools/git/git_1.7.5.1.bb
+++ b/meta/recipes-devtools/git/git_1.7.5.1.bb
@@ -1,6 +1,6 @@
require git.inc
-PR = "r0"
+PR = "r2"
EXTRA_OECONF += "ac_cv_snprintf_returns_bogus=no ac_cv_c_c99_format=yes \
ac_cv_fread_reads_directories=${ac_cv_fread_reads_directories=yes} \