aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/guile
diff options
context:
space:
mode:
authorSong.Li <Song.Li@windriver.com>2012-07-28 17:31:45 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-29 10:14:15 +0100
commit018d5b87bdf00e85fe34e6276bd99e118843d704 (patch)
treef444e17d2efa9a428dc945f748473838a6b08843 /meta/recipes-devtools/guile
parent2792569605b50bdad8b2b8398c823dd08006daf1 (diff)
downloadopenembedded-core-018d5b87bdf00e85fe34e6276bd99e118843d704.tar.gz
guile:meta/Makefile change install-data-hook to install-exec-hook
In guile meta/Makefile, what install-data-hook do must be run after install-binSCRIPTS.so it's a exec hook, not a data hook. If keep these exec-hook in data-hook,when we run make with multi-jobbing , install-data-hook and install-binSCRIPTS will be separately processed in different thread, no any dependence. that will cause error sometimes. [YOCTO #2796] Signed-off-by: Song.Li <Song.Li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/guile')
-rw-r--r--meta/recipes-devtools/guile/files/change-install-data-hook-to-install-exec-hook-in-gui.patch39
-rw-r--r--meta/recipes-devtools/guile/guile_2.0.5.bb3
2 files changed, 41 insertions, 1 deletions
diff --git a/meta/recipes-devtools/guile/files/change-install-data-hook-to-install-exec-hook-in-gui.patch b/meta/recipes-devtools/guile/files/change-install-data-hook-to-install-exec-hook-in-gui.patch
new file mode 100644
index 0000000000..9445fca640
--- /dev/null
+++ b/meta/recipes-devtools/guile/files/change-install-data-hook-to-install-exec-hook-in-gui.patch
@@ -0,0 +1,39 @@
+From 687e5a6598f89b97c89afb94d6ac3ec024dc08e2 Mon Sep 17 00:00:00 2001
+From: "Song.Li" <Song.Li@windriver.com>
+Date: Thu, 26 Jul 2012 14:19:46 +0800
+Subject: [PATCH] guile:meta/Makefile change install-data-hook to install-exec-hook
+
+In guile meta/Makefile, what install-data-hook do
+must be run after install-binSCRIPTS.so it's a exec hook, not a data hook.
+If keep these exec-hook in data-hook,when we run make with multi-jobbing ,
+install-data-hook and install-binSCRIPTS will be separately
+processed in different thread, no any dependence.
+that will cause error sometimes.
+
+[YOCTO #2796]
+
+Upstream Status:Submitted
+Upstream Bugid :12015 email:12015@debbugs.gnu.org
+guile bug maillist: bug-guile@gnu.org
+
+Signed-off-by: Song.Li <Song.Li@windriver.com>
+---
+ meta/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meta/Makefile.am b/meta/Makefile.am
+index f26fc44..e603e5c 100644
+--- a/meta/Makefile.am
++++ b/meta/Makefile.am
+@@ -27,7 +27,7 @@ EXTRA_DIST= \
+ guild.in guile-config.in
+
+ # What we now call `guild' used to be known as `guile-tools'.
+-install-data-hook:
++install-exec-hook:
+ cd $(DESTDIR)$(bindir) && rm -f guile-tools$(EXEEXT) && \
+ $(LN_S) guild$(EXEEXT) guile-tools$(EXEEXT)
+
+--
+1.7.9.5
+
diff --git a/meta/recipes-devtools/guile/guile_2.0.5.bb b/meta/recipes-devtools/guile/guile_2.0.5.bb
index 0e21d5e81c..8fae7125f4 100644
--- a/meta/recipes-devtools/guile/guile_2.0.5.bb
+++ b/meta/recipes-devtools/guile/guile_2.0.5.bb
@@ -22,6 +22,7 @@ SRC_URI = "${GNU_MIRROR}/guile/guile-${PV}.tar.gz \
file://guile_2.0.5_fix_cross_compilation.patch \
file://remove-gets.patch \
file://arm_endianness.patch \
+ file://change-install-data-hook-to-install-exec-hook-in-gui.patch \
"
# file://debian/0001-Change-guile-to-guile-X.Y-for-info-pages.patch
@@ -30,7 +31,7 @@ SRC_URI = "${GNU_MIRROR}/guile/guile-${PV}.tar.gz \
SRC_URI[md5sum] = "bcf70d54b44c99cb9acd3f63c5486b4b"
SRC_URI[sha256sum] = "2a026ea6cdbc51ca71bcd9787839debfa45ac5db1e26dc00b30ca9b128b10956"
-PR = "r4"
+PR = "r5"
inherit autotools gettext
BBCLASSEXTEND = "native"