summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/guile
diff options
context:
space:
mode:
authorBogdan Marinescu <bogdan.a.marinescu@intel.com>2012-06-21 14:39:53 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-21 13:41:12 +0100
commite2cc4a44d510e0d473d15f207c1c886db6a5ccf7 (patch)
tree9bf8227d191aab78b05a2745b239ec99c5a7034a /meta/recipes-devtools/guile
parentbece29110ead367fe501641ec83251e5f87f2430 (diff)
downloadopenembedded-core-e2cc4a44d510e0d473d15f207c1c886db6a5ccf7.tar.gz
[PATCH] guile: fix compilation on MIPS/PPC
This commit fixes the guile compilation segfault on MIPS/PPC. Tested by compiling guile with MACHINE=qemumips. [Yocto #2478] Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/guile')
-rw-r--r--meta/recipes-devtools/guile/files/guile_2.0.5_disable_goops_optimizations.patch32
-rw-r--r--meta/recipes-devtools/guile/files/guile_2.0.5_fix_cross_compilation.patch47
-rw-r--r--meta/recipes-devtools/guile/guile_2.0.5.bb4
3 files changed, 82 insertions, 1 deletions
diff --git a/meta/recipes-devtools/guile/files/guile_2.0.5_disable_goops_optimizations.patch b/meta/recipes-devtools/guile/files/guile_2.0.5_disable_goops_optimizations.patch
new file mode 100644
index 0000000000..8609775310
--- /dev/null
+++ b/meta/recipes-devtools/guile/files/guile_2.0.5_disable_goops_optimizations.patch
@@ -0,0 +1,32 @@
+commit f7d8efc630ce45f5d82aae5b2682d261e5541d5f
+Author: Andy Wingo <wingo@pobox.com>
+Date: Sun Apr 15 13:00:30 2012 -0700
+
+ disable optimizations in goops dispatch procedures
+
+ * module/oop/goops/dispatch.scm: Disable peval and cse.
+
+Upstream-Status: Backported
+
+diff --git a/module/oop/goops/dispatch.scm b/module/oop/goops/dispatch.scm
+index e433b86..b12ab15 100644
+--- a/module/oop/goops/dispatch.scm
++++ b/module/oop/goops/dispatch.scm
+@@ -1,4 +1,4 @@
+-;;;; Copyright (C) 1999, 2000, 2001, 2003, 2006, 2009 Free Software Foundation, Inc.
++;;;; Copyright (C) 1999, 2000, 2001, 2003, 2006, 2009, 2012 Free Software Foundation, Inc.
+ ;;;;
+ ;;;; This library is free software; you can redistribute it and/or
+ ;;;; modify it under the terms of the GNU Lesser General Public
+@@ -178,7 +178,9 @@
+ '())
+ (acons gf gf-sym '()))))
+ (define (comp exp vals)
+- (let ((p ((@ (system base compile) compile) exp #:env *dispatch-module*)))
++ (let ((p ((@ (system base compile) compile) exp
++ #:env *dispatch-module*
++ #:opts '(#:partial-eval? #f #:cse? #f))))
+ (apply p vals)))
+
+ ;; kick it.
+
diff --git a/meta/recipes-devtools/guile/files/guile_2.0.5_fix_cross_compilation.patch b/meta/recipes-devtools/guile/files/guile_2.0.5_fix_cross_compilation.patch
new file mode 100644
index 0000000000..b81f02e82a
--- /dev/null
+++ b/meta/recipes-devtools/guile/files/guile_2.0.5_fix_cross_compilation.patch
@@ -0,0 +1,47 @@
+commit f3b312a19d70293d7a3407fc4ef479183edd7cca
+Author: Ludovic Courtès <ludo@gnu.org>
+Date: Wed Jun 20 01:11:44 2012 +0200
+
+ Fix cross-compilation of GOOPS-using code.
+
+ Fixes <http://bugs.gnu.org/11645>.
+ Reported by Bogdan A. Marinescu <bogdan.a.marinescu@intel.com>.
+
+ * module/oop/goops/dispatch.scm (compute-dispatch-procedure)[comp]:
+ Wrap `compile' call in (with-target %host-type ...).
+
+Upstream-Status: Backported
+
+diff --git a/module/oop/goops/dispatch.scm b/module/oop/goops/dispatch.scm
+index b12ab15..de5359f 100644
+--- a/module/oop/goops/dispatch.scm
++++ b/module/oop/goops/dispatch.scm
+@@ -25,6 +25,7 @@
+ #:use-module (oop goops)
+ #:use-module (oop goops util)
+ #:use-module (oop goops compile)
++ #:use-module (system base target)
+ #:export (memoize-method!)
+ #:no-backtrace)
+
+@@ -178,11 +179,15 @@
+ '())
+ (acons gf gf-sym '()))))
+ (define (comp exp vals)
+- (let ((p ((@ (system base compile) compile) exp
+- #:env *dispatch-module*
+- #:opts '(#:partial-eval? #f #:cse? #f))))
+- (apply p vals)))
+-
++ ;; When cross-compiling Guile itself, the native Guile must generate
++ ;; code for the host.
++ (with-target %host-type
++ (lambda ()
++ (let ((p ((@ (system base compile) compile) exp
++ #:env *dispatch-module*
++ #:opts '(#:partial-eval? #f #:cse? #f))))
++ (apply p vals)))))
++
+ ;; kick it.
+ (scan))
+
diff --git a/meta/recipes-devtools/guile/guile_2.0.5.bb b/meta/recipes-devtools/guile/guile_2.0.5.bb
index db75863d34..cf222a6f47 100644
--- a/meta/recipes-devtools/guile/guile_2.0.5.bb
+++ b/meta/recipes-devtools/guile/guile_2.0.5.bb
@@ -18,6 +18,8 @@ SRC_URI = "${GNU_MIRROR}/guile/guile-${PV}.tar.gz \
file://debian/0003-Mark-mutex-with-owner-not-retained-threads-test-as-u.patch \
file://opensuse/guile-64bit.patch \
file://guile_2.0.5_fix_sed_error.patch \
+ file://guile_2.0.5_disable_goops_optimizations.patch \
+ file://guile_2.0.5_fix_cross_compilation.patch \
"
# file://debian/0001-Change-guile-to-guile-X.Y-for-info-pages.patch
@@ -26,7 +28,7 @@ SRC_URI = "${GNU_MIRROR}/guile/guile-${PV}.tar.gz \
SRC_URI[md5sum] = "bcf70d54b44c99cb9acd3f63c5486b4b"
SRC_URI[sha256sum] = "2a026ea6cdbc51ca71bcd9787839debfa45ac5db1e26dc00b30ca9b128b10956"
-PR = "r0"
+PR = "r1"
inherit autotools gettext
BBCLASSEXTEND = "native"