summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/icon-naming-utils
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-07-18 08:57:31 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-21 10:46:45 +0100
commita788f8262481706d5311eb9b2573f2d69ab2a5d6 (patch)
tree3c488d41429fe994de3cf62bd3e8e00fbe5df439 /meta/recipes-devtools/icon-naming-utils
parent682a213dc732074985bf86f508305fc6eafe18d9 (diff)
downloadopenembedded-core-a788f8262481706d5311eb9b2573f2d69ab2a5d6.tar.gz
icon-naming-utils-native: Fix long path to perl in icon-name-mapping
This is 5396e0868cf89787746fa6341ddb1f271a770595 in oe.dev but here we instead use the nativeperl wrapper. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'meta/recipes-devtools/icon-naming-utils')
-rw-r--r--meta/recipes-devtools/icon-naming-utils/icon-naming-utils-native_0.8.7.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-devtools/icon-naming-utils/icon-naming-utils-native_0.8.7.bb b/meta/recipes-devtools/icon-naming-utils/icon-naming-utils-native_0.8.7.bb
index d34fb0315d..4760c9627e 100644
--- a/meta/recipes-devtools/icon-naming-utils/icon-naming-utils-native_0.8.7.bb
+++ b/meta/recipes-devtools/icon-naming-utils/icon-naming-utils-native_0.8.7.bb
@@ -1,6 +1,6 @@
LICENSE = "GPLv2"
DEPENDS = "libxml-simple-perl-native"
-PR = "r2"
+PR = "r3"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
@@ -9,3 +9,8 @@ SRC_URI = "http://tango.freedesktop.org/releases/icon-naming-utils-0.8.7.tar.gz"
S = "${WORKDIR}/icon-naming-utils-${PV}"
inherit autotools native perlnative
+
+do_configure_append() {
+ # Make sure we use our nativeperl wrapper.
+ sed -i -e "1s:#!.*:#!/usr/bin/env nativeperl:" ${S}/icon-name-mapping.pl.in
+}