aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/installer
diff options
context:
space:
mode:
authorLianhao Lu <lianhao.lu@intel.com>2011-08-19 13:14:27 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-23 18:23:14 -0700
commit125eae393a3448e1ff5f3c2cf782ed7b3aa23920 (patch)
treeafb1d118650d23ee4e9ff01704376a434a50b498 /meta/recipes-devtools/installer
parentac75c4cc27494e93ad8eba318582b875fea8f508 (diff)
downloadopenembedded-core-125eae393a3448e1ff5f3c2cf782ed7b3aa23920.tar.gz
adt-installer: Removed the hard coded repo url.
[YOCTO #1380] Removed the hard coded repo url in opkg configuration files. Signed-off-by: Lianhao Lu <lianhao.lu@intel.com>
Diffstat (limited to 'meta/recipes-devtools/installer')
-rw-r--r--meta/recipes-devtools/installer/adt-installer/opkg/conf/opkg-sdk-i686.conf2
-rw-r--r--meta/recipes-devtools/installer/adt-installer/opkg/conf/opkg-sdk-x86_64.conf2
-rw-r--r--meta/recipes-devtools/installer/adt-installer_1.0.bb5
3 files changed, 6 insertions, 3 deletions
diff --git a/meta/recipes-devtools/installer/adt-installer/opkg/conf/opkg-sdk-i686.conf b/meta/recipes-devtools/installer/adt-installer/opkg/conf/opkg-sdk-i686.conf
index 9c93a72a87..71c62e882e 100644
--- a/meta/recipes-devtools/installer/adt-installer/opkg/conf/opkg-sdk-i686.conf
+++ b/meta/recipes-devtools/installer/adt-installer/opkg/conf/opkg-sdk-i686.conf
@@ -2,4 +2,4 @@ arch all 1
arch any 6
arch noarch 11
arch i686-nativesdk 16
-src yp-i686-nativesdk http://adtrepo.yoctoproject.org/1.0/adt-ipk/i686-nativesdk
+src yp-i686-nativesdk ADTREPO_URL/adt-ipk/i686-nativesdk
diff --git a/meta/recipes-devtools/installer/adt-installer/opkg/conf/opkg-sdk-x86_64.conf b/meta/recipes-devtools/installer/adt-installer/opkg/conf/opkg-sdk-x86_64.conf
index 3e70aac9f0..f0d0634ab4 100644
--- a/meta/recipes-devtools/installer/adt-installer/opkg/conf/opkg-sdk-x86_64.conf
+++ b/meta/recipes-devtools/installer/adt-installer/opkg/conf/opkg-sdk-x86_64.conf
@@ -2,4 +2,4 @@ arch all 1
arch any 6
arch noarch 11
arch x86_64-nativesdk 16
-src yp-x86_64-nativesdk http://adtrepo.yoctoproject.org/1.0/adt-ipk/x86_64-nativesdk
+src yp-x86_64-nativesdk ADTREPO_URL/adt-ipk/x86_64-nativesdk
diff --git a/meta/recipes-devtools/installer/adt-installer_1.0.bb b/meta/recipes-devtools/installer/adt-installer_1.0.bb
index 0537440a6f..74e1b9f2ba 100644
--- a/meta/recipes-devtools/installer/adt-installer_1.0.bb
+++ b/meta/recipes-devtools/installer/adt-installer_1.0.bb
@@ -31,7 +31,7 @@ ALLOW_EMPTY = "1"
PACKAGES = ""
PACKAGE_ARCH = "all"
-PR = "r3"
+PR = "r4"
ADT_DEPLOY = "${TMPDIR}/deploy/sdk/"
ADT_DIR = "${WORKDIR}/adt-installer/"
@@ -54,6 +54,8 @@ SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http \
file://opkg/conf/opkg-sdk-i686.conf \
"
+ADTREPO = "http://adtrepo.yoctoproject.org/${SDK_VERSION}"
+
do_deploy[umask] = 022
fakeroot do_deploy () {
@@ -63,6 +65,7 @@ fakeroot do_deploy () {
rm -rf ${ADT_DIR}
mkdir -p ${ADT_DIR}/opkg/build
cp -r opkg ${ADT_DIR}/
+ sed -i -e 's#ADTREPO_URL#${ADTREPO}#' ${ADT_DIR}/opkg/conf/*.conf
cp -r trunk ${ADT_DIR}/opkg/build/
mv ${ADT_DIR}/opkg/build/trunk ${ADT_DIR}/opkg/build/opkg-svn
cp -r scripts ${ADT_DIR}/