aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/installer
diff options
context:
space:
mode:
authorLiping Ke <liping.ke@intel.com>2011-03-10 17:27:55 +0800
committerSaul Wold <sgw@linux.intel.com>2011-03-10 17:10:51 -0800
commit2e9e8af197671ae06de1bdc9201765b160869d60 (patch)
treeaa9fab41a3d0183c7a97f274284dbdcb4b14ad11 /meta/recipes-devtools/installer
parent5b675f91b17eb9d01a4552506518cc0f7de4eba4 (diff)
downloadopenembedded-core-2e9e8af197671ae06de1bdc9201765b160869d60.tar.gz
Disable wget server side cache
We found some proxy server has wrong cache for long http file name. It will cause fetching wrong ipk files from adt repo. To avoid this, we use wget options --no-cache to disable all server side cache. It will make the fetch speed slower, yet correct always. Signed-off-by: Liping Ke <liping.ke@intel.com> Signed-off-by: Lianhao Lu <lianhao.lu@intel.com>
Diffstat (limited to 'meta/recipes-devtools/installer')
-rw-r--r--meta/recipes-devtools/installer/adt-installer_1.0.bb3
-rw-r--r--meta/recipes-devtools/installer/files/wget_cache.patch10
2 files changed, 12 insertions, 1 deletions
diff --git a/meta/recipes-devtools/installer/adt-installer_1.0.bb b/meta/recipes-devtools/installer/adt-installer_1.0.bb
index 50290f9ffd..ff7afe6623 100644
--- a/meta/recipes-devtools/installer/adt-installer_1.0.bb
+++ b/meta/recipes-devtools/installer/adt-installer_1.0.bb
@@ -36,11 +36,13 @@ PR = "r0"
ADT_DEPLOY = "${TMPDIR}/deploy/sdk/"
ADT_DIR = "${WORKDIR}/adt-installer/"
YOCTOADT_VERSION = "${SDK_VERSION}"
+S = "${WORKDIR}/trunk"
inherit deploy
PV = "0.1.8+svnr${SRCPV}"
SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http \
+ file://wget_cache.patch \
file://adt_installer \
file://scripts/adt_installer_internal \
file://scripts/util \
@@ -70,7 +72,6 @@ fakeroot do_deploy () {
cp ${WORKDIR}/adt_installer.tar.bz2 ${ADT_DEPLOY}
}
-do_patch[noexec] = "1"
do_install[noexec] = "1"
do_configure[noexec] = "1"
do_compile[noexec] = "1"
diff --git a/meta/recipes-devtools/installer/files/wget_cache.patch b/meta/recipes-devtools/installer/files/wget_cache.patch
new file mode 100644
index 0000000000..6fd38e5fc4
--- /dev/null
+++ b/meta/recipes-devtools/installer/files/wget_cache.patch
@@ -0,0 +1,10 @@
+--- trunk/libopkg/opkg_download.c 2011-03-10 16:41:29.000000000 +0800
++++ trunk/libopkg/opkg_download.c 2011-03-10 16:42:33.000000000 +0800
+@@ -162,6 +162,7 @@
+
+ argv[i++] = "wget";
+ argv[i++] = "-q";
++ argv[i++] = "--no-cache";
+ if (conf->http_proxy || conf->ftp_proxy) {
+ argv[i++] = "-Y";
+ argv[i++] = "on";