summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool/libtool-native_2.4.4.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-01-06 14:47:37 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-23 11:35:24 +0000
commit871dc461b1dfc431c0c95743af1624b781262bce (patch)
treeef4bdfc1be6a11b7e339709c77b16b125cd67418 /meta/recipes-devtools/libtool/libtool-native_2.4.4.bb
parent455edf38e8af854de0cffffdebf258b354ff7e54 (diff)
downloadopenembedded-core-871dc461b1dfc431c0c95743af1624b781262bce.tar.gz
libtool: upgraded to 2.4.4
* Upgrade: - libtool-native - libtool-cross - nativesdk-libtool - libtool * Remove 2 patches: - respect-fstack-protector.patch: already in the new source. - avoid_absolute_paths_for_general_utils.patch: no general.m4sh any more. - Use inline-source to install libtoolize. * Update other patches * The LIC_FILES_CHKSUM is changed because of the indent, the contents are the same. * The libtool config files are put in libtool/build-aux now, it was libtool/config in the past. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/libtool/libtool-native_2.4.4.bb')
-rw-r--r--meta/recipes-devtools/libtool/libtool-native_2.4.4.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool-native_2.4.4.bb b/meta/recipes-devtools/libtool/libtool-native_2.4.4.bb
new file mode 100644
index 0000000000..4c5218ade0
--- /dev/null
+++ b/meta/recipes-devtools/libtool/libtool-native_2.4.4.bb
@@ -0,0 +1,22 @@
+require libtool-${PV}.inc
+
+DEPENDS = ""
+
+SRC_URI += "file://prefix.patch"
+
+inherit native
+
+EXTRA_OECONF = " --with-libtool-sysroot=${STAGING_DIR_NATIVE}"
+
+do_configure_prepend () {
+ # Remove any existing libtool m4 since old stale versions would break
+ # any upgrade
+ rm -f ${STAGING_DATADIR}/aclocal/libtool.m4
+ rm -f ${STAGING_DATADIR}/aclocal/lt*.m4
+}
+
+do_install () {
+ autotools_do_install
+ install -d ${D}${bindir}/
+ install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/${HOST_SYS}-libtool
+}