aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/linuxdoc-tools
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2011-02-24 15:57:32 -0800
committerRichard Purdie <rpurdie@linux.intel.com>2011-03-01 11:46:40 +0000
commitb0384f6fb1099d25c42538eb018a25da7a4b2e19 (patch)
treec173a09c34da98a93823a02e9b1f4684e99c17e4 /meta/recipes-devtools/linuxdoc-tools
parent945a86801b0e94834b0bced3f9dc8b1db699588a (diff)
downloadopenembedded-core-b0384f6fb1099d25c42538eb018a25da7a4b2e19.tar.gz
linuxdoc-tools-native: new recipe v0.99.6
This package includes utilities such as sgml2html and sgml2txt, which are used by other packages (e.g, libuser) for building documentation. Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta/recipes-devtools/linuxdoc-tools')
-rw-r--r--meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native/disable_sgml2rtf.patch49
-rw-r--r--meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native_0.9.66.bb21
2 files changed, 70 insertions, 0 deletions
diff --git a/meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native/disable_sgml2rtf.patch b/meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native/disable_sgml2rtf.patch
new file mode 100644
index 0000000000..0fcacebf2b
--- /dev/null
+++ b/meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native/disable_sgml2rtf.patch
@@ -0,0 +1,49 @@
+The build of sgml2rtf is problematic due to the way it wants to
+link to a shared library version of flex. Flex only ships with a
+static lib. Rather than diverging from upstream flex, simply skip
+building this un-needed utility.
+
+Signed-off-by: Scott Garman <scott.a.garman@intel.com>
+diff -urN linuxdoc-tools-0.9.66.orig//Makefile.in linuxdoc-tools-0.9.66/Makefile.in
+--- linuxdoc-tools-0.9.66.orig//Makefile.in 2009-11-09 11:58:25.000000000 -0800
++++ linuxdoc-tools-0.9.66/Makefile.in 2011-02-24 15:37:46.556937051 -0800
+@@ -40,7 +40,7 @@
+ pkgdata_ddir = $(DESTDIR)$(pkgdatadir)
+ tex_ddir = $(DESTDIR)$(texdir)
+
+-progs := sgml2html sgml2info sgml2latex sgml2lyx sgml2rtf sgml2txt sgmlcheck
++progs := sgml2html sgml2info sgml2latex sgml2lyx sgml2txt sgmlcheck
+
+ OPTIMIZE = -O
+
+@@ -64,9 +64,9 @@
+ @echo "Compiling preprocessor (in sgmlpre/)..."
+ ( cd sgmlpre ; \
+ $(MAKE) CFLAGS="$(OPTIMIZE)" LEX=flex sgmlpre || exit -1 )
+- @echo "Compiling RTF conversion tools (in rtf-fix/)..."
+- ( cd rtf-fix ; \
+- $(MAKE) CFLAGS="$(OPTIMIZE)" || exit -1 )
++# @echo "Compiling RTF conversion tools (in rtf-fix/)..."
++# ( cd rtf-fix ; \
++# $(MAKE) CFLAGS="$(OPTIMIZE)" || exit -1 )
+ @echo "making man pages in genman ..."
+ if [ ! -d genman ]; then mkdir genman ; fi
+ for ii in man/* ; do \
+@@ -109,7 +109,7 @@
+
+ # -- Install auxiliary programs
+ mkdir -p $(auxbin_ddir)
+- for ii in sgmlpre/sgmlpre rtf-fix/rtf2rtf; do \
++ for ii in sgmlpre/sgmlpre; do \
+ bn=`basename $$ii`; \
+ $(INSTALL_PROGRAM) $$ii $(auxbin_ddir)/$$bn; \
+ done
+@@ -198,7 +198,7 @@
+
+ clean::
+ -rm -f *~ bin/*~ bin/linuxdoc
+- for d in $(DDIRS) $(MDIRS) rtf-fix; do $(MAKE) -C $$d clean; done
++ for d in $(DDIRS) $(MDIRS); do $(MAKE) -C $$d clean; done
+ (cd sgmlpre ; rm -f sgmlpre.o sgmlpre)
+ -rm -rf genman/
+
diff --git a/meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native_0.9.66.bb b/meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native_0.9.66.bb
new file mode 100644
index 0000000000..f3cd19571b
--- /dev/null
+++ b/meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native_0.9.66.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Convert LinuxDoc SGML source into other formats"
+DESCRIPTION = "Convert LinuxDoc SGML source into other formats"
+HOMEPAGE = "http://packages.debian.org/linuxdoc-tools"
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5fbccc46cff2379505ca4e09c7d6ccfe"
+
+DEPENDS = "openjade-native"
+
+PR = "r0"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/l/linuxdoc-tools/linuxdoc-tools_${PV}.tar.gz \
+ file://disable_sgml2rtf.patch"
+
+SRC_URI[md5sum] = "f214e79b0dd084689cd04f18722bd563"
+SRC_URI[sha256sum] = "128cabb52ef8fb2f370ee488ea92bf4d8e49859200c7c8cae807abfe860a62ec"
+
+inherit autotools native
+
+do_configure () {
+ oe_runconf
+}