aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/make
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2011-12-01 17:21:25 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-01 10:43:37 +0000
commitc2094366ea0771c520d52f0b73b8df1bd74e7941 (patch)
treed11e58c8bfbcebf186838bfcf10d7871a917a0d2 /meta/recipes-devtools/make
parentf782789dd70af8046abb9fd1e05f153e0a9d458c (diff)
downloadopenembedded-core-c2094366ea0771c520d52f0b73b8df1bd74e7941.tar.gz
make: expand MAKEFLAGS before we re-exec after rebuilding makefiles.
This patch was got from the upstream cvs repo of make to fix the bug of make-3.82: http://savannah.gnu.org/bugs/?30723 RP: Tweaked patch status to Backport Signed-off-by: Dexuan Cui <dexuan.cui@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/make')
-rw-r--r--meta/recipes-devtools/make/make-3.82/expand_MAKEFLAGS.patch39
-rw-r--r--meta/recipes-devtools/make/make_3.82.bb4
2 files changed, 42 insertions, 1 deletions
diff --git a/meta/recipes-devtools/make/make-3.82/expand_MAKEFLAGS.patch b/meta/recipes-devtools/make/make-3.82/expand_MAKEFLAGS.patch
new file mode 100644
index 0000000000..941365fa2a
--- /dev/null
+++ b/meta/recipes-devtools/make/make-3.82/expand_MAKEFLAGS.patch
@@ -0,0 +1,39 @@
+Upstream-Status: Backport [The fix is already in upstream cvs repo, but not in the stable release]
+
+When working on the self-hosted-image work, I found in the target
+"bitbake eglibc-initial -c install" always failed:
+
+make[1]: Entering directory `/raid/pe2/build/tmp/work/i586-poky-linux/eglibc-initial-2.13-r18+svnr14157/eglibc-2_13/libc'
+/usr/bin/install -c -m 644 include/limits.h /usr/include/limits.h
+/usr/bin/install: cannot remove `/usr/include/limits.h': Permission denied
+make[1]: *** [/usr/include/limits.h] Error 1
+make[1]: Leaving directory `/raid/pe2/build/tmp/work/i586-poky-linux/eglibc-initial-2.13-r18+svnr14157/eglibc-2_13/libc'
+make: *** [install-headers] Error 2
+ERROR: oe_runmake faile
+
+Debugging shows the install_root variable in eglibc's makefiles is strangely
+reset at some place.
+
+Further investigation shows this is a bug of make-3.82:
+
+http://savannah.gnu.org/bugs/?30723
+http://cvs.savannah.gnu.org/viewvc/make/main.c?root=make&r1=1.243&r2=1.244
+http://old.nabble.com/-bug--30723--implicit-re-executing-of-subdirs-breaks-$(origin)-with-make-3.82-td29394353.html
+
+The patch was got from the second link above(the upstream cvs repo of make).
+
+Thu Dec 1 16:05:59 CST 2011
+Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
+
+diff -Nru make-3.82.orig//main.c make-3.82/main.c
+--- make-3.82.orig//main.c 2010-07-19 15:10:53.000000000 +0800
++++ make-3.82/main.c 2011-12-01 16:04:11.818522186 +0800
+@@ -2093,7 +2093,7 @@
+ const char *pv = define_makeflags (1, 1);
+ char *p = alloca (sizeof ("MAKEFLAGS=") + strlen (pv) + 1);
+ sprintf (p, "MAKEFLAGS=%s", pv);
+- putenv (p);
++ putenv (allocated_variable_expand (p));
+ }
+
+ if (ISDB (DB_BASIC))
diff --git a/meta/recipes-devtools/make/make_3.82.bb b/meta/recipes-devtools/make/make_3.82.bb
index 61fbb324d1..bea33397b5 100644
--- a/meta/recipes-devtools/make/make_3.82.bb
+++ b/meta/recipes-devtools/make/make_3.82.bb
@@ -1,8 +1,10 @@
-PR = "r0"
+PR = "r1"
LICENSE="GPLv3&LGPLv2"
LIC_FILES_CHKSUM = "file://tests/COPYING;md5=d32239bcb673463ab874e80d47fae504 \
file://glob/COPYING.LIB;md5=4a770b67e6be0f60da244beb2de0fce4"
require make.inc
+SRC_URI += "file://expand_MAKEFLAGS.patch"
+
SRC_URI[md5sum] = "1a11100f3c63fcf5753818e59d63088f"
SRC_URI[sha256sum] = "e2c1a73f179c40c71e2fe8abf8a8a0688b8499538512984da4a76958d0402966"