aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-05-23 14:19:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-25 07:49:54 +0100
commit72792a2fd900fe86d18bd8e330bc0535e2eeb80d (patch)
treef37afc93616efb811b1067d4797370bba728eb36 /meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
parent50d63fa346bbb05dafffc0cb55e21e1092272d95 (diff)
downloadopenembedded-core-72792a2fd900fe86d18bd8e330bc0535e2eeb80d.tar.gz
mkelfimage: fix compile issues
This fixes a couple issues introduced by the previous patch. There were a couple spots where HOST_CFLAGS needed changing to CFLAGS. This fixes builds with security_flags. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/mkelfimage/mkelfimage_git.bb')
-rw-r--r--meta/recipes-devtools/mkelfimage/mkelfimage_git.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb b/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
index d7a4429fb8..2bcc8d7bd9 100644
--- a/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
+++ b/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
@@ -24,8 +24,11 @@ CLEANBROKEN = "1"
S = "${WORKDIR}/git/util/mkelfImage"
CFLAGS += "-fno-stack-protector"
-CACHED_CONFIGUREVARS += "HOST_CC='${BUILD_CC}'"
-EXTRA_OEMAKE += "HOST_CPPFLAGS='${BUILD_CPPFLAGS}'"
+CACHED_CONFIGUREVARS += "\
+ HOST_CC='${BUILD_CC}' \
+ HOST_CFLAGS='${BUILD_CFLAGS}' \
+ HOST_CPPFLAGS='${BUILD_CPPFLAGS}' \
+"
inherit autotools-brokensep