aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
diff options
context:
space:
mode:
authorEmilia Ciobanu <emilia.maria.silvia.ciobanu@intel.com>2013-07-03 18:02:49 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-07-05 15:26:20 +0100
commit8a9a476c03a3bc2782206799933d92e216032ff7 (patch)
tree2eae813453f0c6622002dc9f9d0a92daba5322bf /meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
parent20b9151f877978c086dcc8cbae7e0d9c9e89a45d (diff)
downloadopenembedded-core-8a9a476c03a3bc2782206799933d92e216032ff7.tar.gz
mkelfimage: switch to git repository
The project has switched to using git for version control. Signed-off-by: Emilia Ciobanu <emilia.maria.silvia.ciobanu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/mkelfimage/mkelfimage_git.bb')
-rw-r--r--meta/recipes-devtools/mkelfimage/mkelfimage_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb b/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
new file mode 100644
index 0000000000..8d232bbb3f
--- /dev/null
+++ b/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "A utility to create ELF boot images for ELF-based Linux kernel images"
+HOMEPAGE = "http://www.coreboot.org/Mkelfimage"
+SECTION = "devel"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=ea5bed2f60d357618ca161ad539f7c0a"
+
+SRCREV = "686a48a339b3200184c27e7f98d4c03180b2be6c"
+PV = "4.0+git${SRCPV}"
+PR = "r0"
+
+DEPENDS += "zlib"
+
+SRC_URI = "git://review.coreboot.org/p/coreboot;protocol=http \
+ file://cross-compile.patch \
+ file://fix-makefile-to-find-libz.patch \
+ "
+
+S = "${WORKDIR}/git/util/mkelfImage"
+
+CFLAGS += "-fno-stack-protector"
+CACHED_CONFIGUREVARS += "HOST_CC='${BUILD_CC}'"
+EXTRA_OEMAKE += "HOST_CPPFLAGS='${BUILD_CPPFLAGS}'"
+
+inherit autotools
+
+do_install_append() {
+ rmdir ${D}${datadir}/mkelfImage/elf32-i386
+ rmdir ${D}${datadir}/mkelfImage
+}
+
+BBCLASSEXTEND = "native"