aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/mtools
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-01-26 11:14:34 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-26 22:31:10 +0000
commitc03cdb8a9f1929d9ef03c55b8b18d60ff69db447 (patch)
tree3a13a36c626646dd516a7482785236619dc99e5e /meta/recipes-devtools/mtools
parent5eb8f15c48b5f39a10eb2b63b026cf1ebfd05533 (diff)
downloadopenembedded-core-c03cdb8a9f1929d9ef03c55b8b18d60ff69db447.tar.gz
mtools: keep v3.9.9 recipe in sync with the v4.0.18 version
Changes are mostly cosmetic, but also include one important fix to support builds using musl libc. http://git.openembedded.org/openembedded-core/commit/?id=9f5eb272784d3be17e7fe8e7cab511bd4086ba1e Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/mtools')
-rw-r--r--meta/recipes-devtools/mtools/mtools_3.9.9.bb36
1 files changed, 19 insertions, 17 deletions
diff --git a/meta/recipes-devtools/mtools/mtools_3.9.9.bb b/meta/recipes-devtools/mtools/mtools_3.9.9.bb
index c284a71b4e..26d52a9842 100644
--- a/meta/recipes-devtools/mtools/mtools_3.9.9.bb
+++ b/meta/recipes-devtools/mtools/mtools_3.9.9.bb
@@ -1,16 +1,15 @@
-# mtools OE build file
-# Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved
-# Released under the MIT license (see packages/COPYING)
-
SUMMARY = "Utilities to access MS-DOS disks without mounting them"
-DESCRIPTION = "Mtools is a collection of utilities for accessing MS-DOS disks from Unix without mounting them."
+DESCRIPTION = "Mtools is a collection of utilities to access MS-DOS disks from GNU and Unix without mounting them."
HOMEPAGE = "http://www.gnu.org/software/mtools/"
+SECTION = "optional"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=92b58ec77696788ce278b044d2a8e9d3"
PR = "r6"
-RDEPENDS_${PN} = "glibc-gconv-ibm850"
-RRECOMMENDS_${PN} = "\
+DEPENDS += "virtual/libiconv"
+
+RDEPENDS_${PN}_libc-glibc = "glibc-gconv-ibm850"
+RRECOMMENDS_${PN}_libc-glibc = "\
glibc-gconv-ibm437 \
glibc-gconv-ibm737 \
glibc-gconv-ibm775 \
@@ -26,24 +25,22 @@ RRECOMMENDS_${PN} = "\
glibc-gconv-ibm866 \
glibc-gconv-ibm869 \
"
-
-#http://mtools.linux.lu/mtools-${PV}.tar.gz
-SRC_URI = "http://downloads.yoctoproject.org/mirror/sources/mtools-${PV}.tar.gz \
- file://mtools-makeinfo.patch \
- file://mtools.patch \
- file://no-x11.patch \
- file://fix-broken-lz.patch \
-"
-
SRC_URI[md5sum] = "3e68b857b4e1f3a6521d1dfefbd30a36"
SRC_URI[sha256sum] = "af083a73425d664d4607ef6c6564fd9319a0e47ee7c105259a45356cb834690e"
-S = "${WORKDIR}/mtools-${PV}"
+#http://mtools.linux.lu/mtools-${PV}.tar.gz
+SRC_URI = "http://downloads.yoctoproject.org/mirror/sources/mtools-${PV}.tar.gz \
+ file://mtools-makeinfo.patch \
+ file://mtools.patch \
+ file://no-x11.patch \
+ file://fix-broken-lz.patch"
inherit autotools texinfo
EXTRA_OECONF = "--without-x"
+LDFLAGS_append_libc-uclibc = " -liconv "
+
BBCLASSEXTEND = "native nativesdk"
PACKAGECONFIG ??= ""
@@ -54,3 +51,8 @@ do_install_prepend () {
mkdir -p ${D}/${bindir}
mkdir -p ${D}/${datadir}
}
+
+do_install_append_class-native () {
+ create_wrapper ${D}${bindir}/mcopy \
+ GCONV_PATH=${libdir}/gconv
+}