summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg-utils
diff options
context:
space:
mode:
authorChristopher Larson <kergoth@gmail.com>2012-01-04 22:30:37 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-05 11:18:39 +0000
commit118cb063b08fc1aeb99c248fde6ef2069496c347 (patch)
treed5ef9a63b98513672e67439cca837db71252abfe /meta/recipes-devtools/opkg-utils
parent3b01b884dac0b31af8f5f2ebd60e5939e0111873 (diff)
downloadopenembedded-core-118cb063b08fc1aeb99c248fde6ef2069496c347.tar.gz
opkg-utils: use /usr/bin/env python
Signed-off-by: Christopher Larson <kergoth@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opkg-utils')
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils/shebang.patch46
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb3
2 files changed, 48 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils/shebang.patch b/meta/recipes-devtools/opkg-utils/opkg-utils/shebang.patch
new file mode 100644
index 0000000000..f6a2ef9bdf
--- /dev/null
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils/shebang.patch
@@ -0,0 +1,46 @@
+Use python via the PATH, rather than hardcoding /usr/bin/python
+
+Upstream-Status: Pending
+
+Signed-off-by: Christopher Larson <kergoth@gmail.com>
+
+--- opkg-utils.orig/opkg-list-fields
++++ opkg-utils/opkg-list-fields
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/env python
+
+ import sys, opkg
+
+--- opkg-utils.orig/opkg-make-index
++++ opkg-utils/opkg-make-index
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/env python
+
+ import sys, os, posixpath
+ from glob import glob
+--- opkg-utils.orig/opkg-show-deps
++++ opkg-utils/opkg-show-deps
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/env python
+
+ import sys, os, posixpath
+ from glob import glob
+--- opkg-utils.orig/opkg-unbuild
++++ opkg-utils/opkg-unbuild
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/env python
+
+ import sys, os, re
+
+--- opkg-utils.orig/opkg-update-index
++++ opkg-utils/opkg-update-index
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python2.1
++#!/usr/bin/env python
+
+ import sys, os
+ from glob import glob
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb
index 9b94aff023..97021313dc 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb
@@ -8,13 +8,14 @@ RDEPENDS_${PN} = "python"
RDEPENDS_${PN}_virtclass-native = ""
SRCREV = "4747"
PV = "0.1.8+svnr${SRCPV}"
-PR = "r6"
+PR = "r7"
SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http \
file://index-ignore-filenotfound.patch \
file://mtime-int.patch \
file://add-license-field.patch \
file://arfile_header_split.patch \
+ file://shebang.patch \
"
S = "${WORKDIR}/opkg-utils"