aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2015-07-31 18:59:37 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-01 07:38:31 +0100
commita71b29ffc514892ca394fc8de275294b910586f0 (patch)
tree783cbec06ca34a05ee4e3d31d9c44ec223386a6e /meta/recipes-devtools/opkg
parentc9da529943b2f563b7b0aeb43576c13dd3b6f932 (diff)
downloadopenembedded-core-a71b29ffc514892ca394fc8de275294b910586f0.tar.gz
opkg: solve inconsistency of using different lists directories
Default behavior of opkg was to use ${OPKGLIBDIR}/opkg/lists; but in our recipe we modify it to ${OPKGLIBDIR}/opkg/${OPKGLIBDIR}/opkg/, when appending package-management to IMAGE_FEATURES these lists are populated during build time (using the default directory), but since our config was different these populated lists were never used at runtime, this patch solves this inconsistency by using default behavior for both build time and runtime. [YOCTO #6966] Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opkg')
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.2.4.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.2.4.bb b/meta/recipes-devtools/opkg/opkg_0.2.4.bb
index 56df9202b1..b7574e538e 100644
--- a/meta/recipes-devtools/opkg/opkg_0.2.4.bb
+++ b/meta/recipes-devtools/opkg/opkg_0.2.4.bb
@@ -45,7 +45,7 @@ EXTRA_OECONF = "\
do_install_append () {
install -d ${D}${sysconfdir}/opkg
install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf
- echo "option lists_dir ${OPKGLIBDIR}/opkg" >>${D}${sysconfdir}/opkg/opkg.conf
+ echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf
# We need to create the lock directory
install -d ${D}${OPKGLIBDIR}/opkg