summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/packagegroups
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-03 14:45:42 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:55 -0700
commitac510cb82c007f987b481df74c7a5fede81fa85a (patch)
tree740b8af961ee6872257947dc58313a2c501e8e33 /meta/recipes-devtools/packagegroups
parentc48f87a3fa9c61aaeedbcf5712a699c27d940a3b (diff)
downloadopenembedded-core-ac510cb82c007f987b481df74c7a5fede81fa85a.tar.gz
qemu-config: turn into distcc-config and a package group
* Create a new packagegroup-core-device-devel which pulls in everything that qemu-config used to, with the exception of anjuta-remote-run - this is unlikely to be widely used * Move the remainder of qemu-config to distcc-config and allow DISTCC_HOSTS to be configured via a variable of the same name * Use SUMMARY instead of DESCRIPTION for single-line description since DESCRIPTION is defaulted from SUMMARY if not set Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/packagegroups')
-rw-r--r--meta/recipes-devtools/packagegroups/packagegroup-core-device-devel.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-devtools/packagegroups/packagegroup-core-device-devel.bb b/meta/recipes-devtools/packagegroups/packagegroup-core-device-devel.bb
new file mode 100644
index 0000000000..e55eed52e3
--- /dev/null
+++ b/meta/recipes-devtools/packagegroups/packagegroup-core-device-devel.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Provides a small set of tools for development on the device"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+RPROVIDES_${PN} = "qemu-config"
+RREPLACES_${PN} = "qemu-config"
+
+RDEPENDS_${PN} = "\
+ distcc-config \
+ oprofileui-server \
+ nfs-export-root \
+ bash \
+ "
+