summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2014-04-17 11:07:38 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-24 17:54:55 +0100
commitb4f453e435739b2a692980a87504393156aaaaf5 (patch)
treef793f218996147cecbf8907f699924a9925493b4 /meta/recipes-devtools/perl
parent270e82399915d1f620756e380464f984c8a2cda8 (diff)
downloadopenembedded-core-b4f453e435739b2a692980a87504393156aaaaf5.tar.gz
liberror-perl: add 0.17022
This is needed for git-perltools to work: koen@beast:/build/v2014.06/sources/meta-openembedded$ git send-email -M -1 --to openembedded-devel@lists.openembedded.org --subject-prefix=meta-oe][PATCH Can't locate Error.pm in @INC (@INC contains: /usr/lib/perl/5.14.3 /etc/perl /usr/lib/perl/site_perl/5.14.3/ /usr/lib/perl/site_perl/5.14.3 /usr/lib/perl/vendor_perl/5.14.3/ /usr/lib/perl/vendor_perl/5.14.3 /usr/lib/perl/5.14.3/ /usr/local/lib/site_perl .) at /usr/lib/git/git-core/git-send-email line 30. Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/liberror-perl_0.17022.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/liberror-perl_0.17022.bb b/meta/recipes-devtools/perl/liberror-perl_0.17022.bb
new file mode 100644
index 0000000000..071f4b7860
--- /dev/null
+++ b/meta/recipes-devtools/perl/liberror-perl_0.17022.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Error - Error/exception handling in an OO-ish way"
+DESCRIPTION = "The Error package provides two interfaces. Firstly \
+Error provides a procedural interface to exception handling. \
+Secondly Error is a base class for errors/exceptions that can \
+either be thrown, for subsequent catch, or can simply be recorded."
+
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8f3499d09ee74a050c0319391ff9d100"
+
+DEPENDS += "perl"
+
+SRC_URI = "http://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Error-${PV}.tar.gz"
+SRC_URI[md5sum] = "f4d825f4be915ae90bf2e0d66734956b"
+SRC_URI[sha256sum] = "cab74f04fb3af7088cefc2f6f96800ee52d34b82928bbb35ca51a0e5b5f9f7ef"
+
+S = "${WORKDIR}/Error-${PV}"
+
+inherit cpan
+
+do_compile() {
+ export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
+ cpan_do_compile
+}
+
+BBCLASSEXTEND = "native"