summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/postinst-intercept
diff options
context:
space:
mode:
authorDavid Nyström <david.c.nystrom@gmail.com>2014-01-31 10:30:00 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-02 22:34:32 +0000
commit5d5ef0f5620ec525491c53e8457e7c65c226bfb4 (patch)
tree13db388af9685e65504e125239bf57f490e64f8e /meta/recipes-devtools/postinst-intercept
parentddb0c70a7d4d51a1f404c194a562325137222146 (diff)
downloadopenembedded-core-5d5ef0f5620ec525491c53e8457e7c65c226bfb4.tar.gz
postinst-intercept: New recipe to include postinstall intercepts in nativesdk
Adding ability to use postinstalls intercepts in the nativesdk env, and making sure the correlate between repo + SDK. This to enable rootfs generation from a package repository using only a package repository and the toolchain tarball. See https://github.com/nysan/rootfs-sandbox for examples. Signed-off-by: David Nyström <david.nystrom@enea.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/postinst-intercept')
-rw-r--r--meta/recipes-devtools/postinst-intercept/postinst-intercept_1.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/postinst-intercept/postinst-intercept_1.0.bb b/meta/recipes-devtools/postinst-intercept/postinst-intercept_1.0.bb
new file mode 100644
index 0000000000..41b9a6e49e
--- /dev/null
+++ b/meta/recipes-devtools/postinst-intercept/postinst-intercept_1.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Postinstall scriptlets"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+FILES_${PN}_append_class-nativesdk = " ${datadir}/postinst-intercepts/*"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install_append_class-nativesdk() {
+ install -d ${D}${datadir}/postinst-intercepts
+ install -m 755 ${COREBASE}/scripts/postinst-intercepts/postinst_intercept ${D}${datadir}/postinst-intercepts/
+ install -m 755 ${COREBASE}/scripts/postinst-intercepts/update_font_cache ${D}${datadir}/postinst-intercepts/
+ install -m 755 ${COREBASE}/scripts/postinst-intercepts/update_icon_cache ${D}${datadir}/postinst-intercepts/
+ install -m 755 ${COREBASE}/scripts/postinst-intercepts/update_pixbuf_cache ${D}${datadir}/postinst-intercepts/
+}
+
+BBCLASSEXTEND = "nativesdk"
+INHIBIT_DEFAULT_DEPS = "1"